[SOLVED][Telegram] sendTelegramQuery working but I can't receive answer

OH version: openHAB 3.2.0.M1
I’m trying to send a Telegram message with 2 answer options:
getActions("telegram","telegram:telegramBot:xxxxxx").sendTelegramQuery(xxxxxxxxxL, "open garage?", "Reply_Garage", "Yes", "No")
This works, I get this message on my mobile in the bot chat.

But then I’m stuck, I can press “yes” or “no”, the answer never shows in the OH event logs, so doing some stuff with the answer isn’t possible.
Privacy mode for bot is off (if this is necessary at all).

I think, I’m missing something, any help out there?

There is an example on the bottom of the binding docs, you are missing the second part of the rule:

Thanks, I noticed the second part and it is in place but not working since the answer from my phone (yes/no) never reaches my OH instance so the 2nd rule doesn’t start at all.
My Telegram item “TelegramBot_ReplyId” is still NULL

If I write some text in the chat, e.g. “test” then this is send to OH, “TelegramBot_LastMessageText” contains the text “test”.
It seems that the buttons are my problem… (strange at all)

I started with exactly copying the example (except the bot id) and then changed everything to my needs after it was working.

You need to manually trigger this part of the rule:

rule "Send telegram with question"
    Item Presence changed to OFF

Just put a Switch “Presence” or similar on your sitemap and flip it from ON to OFF …

Tried example, didn’t work…

As a last resort, I created a new bot and now all is working! The bot was somehow damaged, the “Yes/No” buttons didn’t work, I have no idea why…

Thanks for your help!

1 Like

Changing the reply_id string helped in my case, but a whole bot will solve this as well of course.