[SOLVED] Telldus-core depends on libconfuse but it is not installable

Hi!

There’s a menu option in openhabian-config that allows you to install telldus-core.

It has worked before (on Debian 9) but it fails on Ubuntu 18.04.3 LTS with the following message:

The following packages have unmet dependencies:
telldus-core : Depends: libconfuse1 (>= 3.0+dfsg~) but it is not installable

The package telldus-core I fetched from

deb https://s3.eu-central-1.amazonaws.com/download.telldus.com unstable main

which is automatically configured by openhabian-config.

After googling about I found this:

My solution was

apt-get install libftdi1 libtelldus-core2
apt-get download telldus-core
dpkg --ignore-depends=libconfuse1 -i telldus-core_2.1.3-beta1-1_amd64.deb

but I’m obviously still missing libconfuse.so.1

The repository added by openhabian-config… is that maintained by anyone here? Perhaps we can make it work with Ubuntu 18?

Unfortunately it’s always a hassle adding the tellstick since there’s always some dependency missing (feels like anyway).

Have you tried installing libconfuse1 ?
I suspect it is automatically installed on Debian and Raspbian but Ubuntu likes doing their own thing.

libconfuse1 is not available in the repositories connected to Ubuntu 18 which is the problem. libconfuse2 is available.

I haven’t found an easy way to cherrypick packages that are not in the distribution but perhaps there’s an easy way to do that which I haven’t yet discovered?

Have you tried using openhabian-config tool selecting “Apply Improvements” and “Install needed packages”?

1 Like

Have you tried using openhabian-config tool selecting “Apply Improvements” and “Install needed packages”?

Yes, that’s why I’m bringing it up as a topic here :slight_smile: Thinking about it, last time I ran into this issue I ended up with installing Debian 9 as a virtual server on my Ubuntu 18 to go around the issue. I’m hoping there are better ways though.

Currently I would say that openhabian-config is not compatible with Telldus-core on Ubuntu.

Telldus-core is not maintained by Telldus any more. On my rpi I was using this guide https://www.kentsvanberg.se/tellduscenter/guide.php, newest raspian have the same libconfuse2 (1) problem.
Tellstick Binding are not working when upgrading to 2.5.0-1 from 2.4.0-1 losing sensors at least. “Telldus Live Gateway” that is my problem. Got back to 2.4.- and sensors came back.

Can you use the command line and try to see what directory libconfuse1 is located? Not sure the exact command but something like $ find . -name |grep libconfuse1

Only if it is already installed. If it is already installed it would likely be in one of the lib folders referenced at the OS level already.

If finding the location on OH 2.4 then upgrading to 2.5 see if it’s in the same location. Maybe there is an issue with it not loading correctly from that location in 2.5 or it’s not there at all???

This is a distribution problem from what I understand. It’s not a matter of finding the libconfuse library. The problem is that it’s depending on an old libconfuse library that isn’t available in Ubuntu 18.
I tried to see if the libraries can co-exist but they can’t since both of them, the required libconfuse1 and the available libconfuse2 both depend on libconfuse-common but in different versions.

Trying a manual install of libconfuse1 taken from Debian 9 repo gives this

sudo dpkg -i libconfuse1_3.0+dfsg-2+deb9u1_amd64.deb
dpkg: dependency problems prevent configuration of libconfuse1:amd64:
libconfuse1:amd64 depends on libconfuse-common (= 3.0+dfsg-2+deb9u1); however:
Version of libconfuse-common on system is 3.2.1+dfsg-4ubuntu0.1.`

As @rhis mentioned this seems to be a problem on newest Raspian as well. If the option of installing telldus-core are to remain in openhabian-config tools I think this needs to be adressed.

Does anyone know what sources are used to compile the telldus core package referred to by openhabian-config?

This source


doesn’t contain

tdtool-improved

but only

tdtool

I can compile the sources above on github with libconfuse2 without any problems, so it seems to be a matter of recompiling and repackaging, but what should be recompiled?

I think the 2.5 repo is here.

Issues should be filed here.

I’m on Debian 10 and had the same problem. I installed libconfuse2 and it did the trick.
I also compiled Telldus-core from sources to 64 bit using this guide R-Pi Tellstick core

1 Like

Thanks for the link @Bruce_Osborne. This particular add-on depends on an external library as stated in the docs.

The telldus-core bridge uses a library on the local computer which is a .dll file for
Windows and a .so file for Linux. The default one is usually correct.

The issue here is that we can’t install that external library, so it’s kind of outside the scope of the 2.5 repo. The external library is provided by the openhabian-config tool but it gets failed dependencies on newer distributions of Linux. However, one solution would be to re-write the addon to talk directly to the tellstick without using that external library.

Thanks for the link @Joachim_Brolin. It’s infomative on how to compile the sources :slight_smile: I will continue to look for the tdtool-improved sources, but for now I’ll probably just settle for Debian 9 on my upcoming installation.

I found the crucial information needed here

which describes how to compile a debian package from source.

My solution for debian based distributions are as follows

# Add telldus repository to apt sources
wget http://download.telldus.com/debian/telldus-public.key
sudo apt-key add telldus-public.key

sudo echo "deb-src https://s3.eu-central-1.amazonaws.com/download.telldus.com unstable main" >> /etc/apt/sources.list.d/telldus-unstable.list

sudo apt-get update

# Get packages needed for general builds
sudo apt-get install build-essential fakeroot devscripts cmake

# Needed to sucessfully run build of telldus-core but not specified as build deps
sudo apt-get install libftdi-dev libconfuse-dev help2man

# Get build deps that are specified in the package telldus core
sudo apt-get build-dep telldus-core

# Add the linker flag for pthread, otherwise linking will fail
export DEB_LDFLAGS_APPEND='-pthread'

# Get the source of telldus core
apt-get source telldus-core

cd telldus-core-2.1.3-beta1/
# Build packages (unsigned)
debuild -b -uc -us

# In case the build complains about a missing Doxyfile.in, create an empty one
touch Doxyfile.in

# Install the newly built packages
sudo dpkg -i libtelldus-core2_2.1.3-beta1-1_amd64.deb
sudo dpkg -i telldus-core_2.1.3-beta1-1_amd64.deb
1 Like