[SOLVED] Tellstick binding fails with no sensors - offline

I’m running a Tellstick net device with the following version of the Tellstick plugin: │ org.openhab.binding.tellstick.

The connection to live.telldus.com works and the devices are found and added to openhab2. But the connection and the devices goes offline…

The problems seems to be related to that I only have devices and no sensors.

And when the updateSensors(sensorList); is executed I get the following error:

2017-12-03 00:23:32.425 [DEBUG] [t.i.l.TelldusLiveBridgeHandler:182 ] - Updated sensors:null
2017-12-03 00:23:32.425 [DEBUG] [t.i.l.TelldusLiveBridgeHandler:193 ] - Update sensors, reset updated flag
2017-12-03 00:23:32.440 [ERROR] [t.i.l.TelldusLiveBridgeHandler:127 ] - Failed to updatejava.lang.NullPointerException: null
at org.openhab.binding.tellstick.internal.live.TelldusLiveBridgeHandler.updateSensors(TelldusLiveBridgeHandler.java:194)
at org.openhab.binding.tellstick.internal.live.TelldusLiveBridgeHandler.refreshDeviceList(TelldusLiveBridgeHandler.java:120)
at org.openhab.binding.tellstick.internal.live.TelldusLiveBridgeHandler$1.run(TelldusLiveBridgeHandler.java:70)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

2017-12-03 00:23:32.447 [INFO ] [ome.event.ThingStatusInfoEvent:52 ] - ‘tellstick:telldus-live:2’ updated: OFFLINE (COMMUNICATION_ERROR)

Someone with more java and openhab2 knowledge, than me, needs to take a look at the following code…

    synchronized void refreshDeviceList() {
        try {
        } catch (TellstickException e) {
            updateStatus(ThingStatus.OFFLINE, ThingStatusDetail.COMMUNICATION_ERROR, e.getMessage());
            logger.error("Failed to update", e);
        } catch (Exception e) {
            updateStatus(ThingStatus.OFFLINE, ThingStatusDetail.COMMUNICATION_ERROR, e.getMessage());
            logger.error("Failed to update", e);

Ok… I have looked at it myself. A pull request to the Tellstick bindning is now waiting for approval.


I’m in exactly the same situation over here… The Tellstick finds my devices, I don’t have any sensors, but everything is offline and I can use the items…
I might also add that it worked just a few days ago… I reinstalled my server and used my old config files, all old items worked then. They were online and I could use the items, but the Tellstick gateway was still offline (communication error). But when I added new devices the new ones did not work… I then tried to remove everything, including the binding, and then readded everything again. Now nothing works, neither the old or new devices…
So, I’m not sure if the lack of sensors are to blaim here? Since it worked yesterday with my old devices… I think it’s another bug that won’t let us add new devices (or re-add old ones)…

Hoping that someone can help us soon! This is quite annoying…

Hi again,

I just tried this one:

Now my gateway is online, and also the items! I’ve just tried a couple of my devices - but they seem to work! So try it out you also! :slight_smile:

Glad to hear my changes helped you out!


1 Like