[SOLVED] Tkb_tz65d as TZ35S

What do you mean with the device ID? The node ID in openhab?
This is node 74…

The module ID is TZ36D, as you can see in the rest api, here below

{
  "statusInfo": {
    "status": "ONLINE",
    "statusDetail": "NONE"
  },
  "editable": true,
  "label": "Sch_2Knops",
  "bridgeUID": "zwave:serial_zstick:2f4ef5d0",
  "configuration": {
    "binding_cmdrepollperiod": 1500,
    "group_4": [
      "controller"
    ],
    "action_failed": false,
    "group_1": [
      "controller"
    ],
    "action_remove": false,
    "group_3": [
      "controller"
    ],
    "binding_pollperiod": 3600,
    "group_2": [
      "controller"
    ],
    "action_heal": false,
    "config_1_1": 1,
    "switchall_mode": 255,
    "config_2_1": 1,
    "action_reinit": false,
    "config_3_1": 1,
    "config_4_1": 0,
    "config_5_1": 0,
    "node_id": 74
  },
  "properties": {
    "zwave_class_basic": "BASIC_TYPE_ROUTING_SLAVE",
    "zwave_class_generic": "GENERIC_TYPE_SWITCH_BINARY",
    "zwave_neighbours": "1,32",
    "modelId": "TZ36D",
    "zwave_version": "2.1",
    "zwave_plus_devicetype": "NODE_TYPE_ZWAVEPLUS_NODE",
    "versionMin": "2.1",
    "vendor": "TKB Home",
    "defaultAssociations": "1,2,3,4",
    "zwave_routing": "true",
    "zwave_beaming": "true",
    "zwave_secure": "false",
    "zwave_class_specific": "SPECIFIC_TYPE_POWER_SWITCH_BINARY",
    "zwave_devicetype": "3",
    "zwave_frequent": "false",
    "zwave_listening": "true",
    "manufacturerId": "0118",
    "manufacturerRef": "0003:0003,0311:0202",
    "dbReference": "605",
    "zwave_deviceid": "3",
    "zwave_nodeid": "74",
    "zwave_lastheal": "2019-08-20T00:38:50Z",
    "zwave_plus_roletype": "ROLE_TYPE_SLAVE_ALWAYS_ON",
    "zwave_manufacturer": "280"
  },
  "UID": "zwave:device:2f4ef5d0:node74",
  "thingTypeUID": "zwave:tkb_tz36d_02_001",
  "channels": [
    {
      "linkedItems": [
        "Sch_2Knops_Binary"
      ],
      "uid": "zwave:device:2f4ef5d0:node74:switch_binary",
      "id": "switch_binary",
      "channelTypeUID": "zwave:switch_binary",
      "itemType": "Switch",
      "kind": "STATE",
      "label": "Switch",
      "description": "Switch the power on and off",
      "defaultTags": [],
      "properties": {
        "binding:*:OnOffType": "COMMAND_CLASS_SWITCH_BINARY,COMMAND_CLASS_BASIC"
      },
      "configuration": {}
    },
    {
      "linkedItems": [
        "Sch_2Knops"
      ],
      "uid": "zwave:device:2f4ef5d0:node74:scene_number",
      "id": "scene_number",
      "channelTypeUID": "zwave:scene_number",
      "itemType": "Number",
      "kind": "STATE",
      "label": "Scene Number",
      "description": "Triggers when a scene button is pressed",
      "defaultTags": [],
      "properties": {
        "binding:*:DecimalType": "COMMAND_CLASS_SCENE_ACTIVATION"
      },
      "configuration": {}
    }
  ],
  "location": "Achtertuin"
}

I was thinking of adding a zwave relay (ZW-A) in the network, that listen to group 4.
Once the button (ZW-B) is pushed, it sends his signal to group 4, and ZW-A gets on.
When ZW-A is being triggered, this can be picked up by OpenHAB?

Or do I see zwave groups the wrong way?

There really is no such concept of a device “listening” to a group.

Yes - it is SENDING a message to the devices that are configured within this devices association group 4. So it you configure a light in group 4, then that light will be switched when you press the button.

I don’t know what you mean by this? If the second switch is trigged through a command, as I think you mean here (??) then it will not send another command to openHAB (sorry - I’m not sure that I understand so apologies if I’ve misinterpreted).

The button is sending a signal to group 4.
And when the light (fe Fibaro Double Relay) in group 4 is switched on, this should be seen by OH, no?
With a simple rule, I should then be able to switch a KNX relay, based on the zwave relay in group 4.

Only if you have the controller in group 4 of the original device.

I came across this topic whilst looking into setting up openHAB with one of the TKB Home light switches.

I don’t know much about how openHAB works but would it be possible when adding a device to check if it is one that shares the device ID? If it does share the device ID then you could have a dropdown to select the correct device.

This seems like it would work for all devices that share device IDs without having to hard code fixes for each set of shared devices. I guess this is where you tell me my understanding is all wrong!

The 3 pieces of manufacturer, device type, & device ID (and sometimes formare version) are what is used to uniquely identify the device as per the Z-Wave standard. You cannot change a primary database key.

Hi I have exactly the same issue as you with the same device TZ65D being recognised as a TZ35S. I have downloaded the two .sh files. Can you explain to me how to make the changes? I tried running the -jar script but if fails?

Many thx in advance!

Vincent

Did you find a fix for this?

The fix for this is to buy a device where the manufacturer does not reuse the same ID for multiple devices. There is no other way to identify them.

They are defective by design.

Thats not so good, i’ve a few of them about the house and use the second paddle to control other devices

Migrating away from Vera to OpenHAB, all the other devices so far have worked great in OpenHAB, a much better platform!