[SOLVED] Tkb_tz65d as TZ35S

Hi @chris, afer upgrading openhab all my switches (TKB home TZ65D) appear in the INBOX with wrong type - as TZ35S.
I have three kinds of TKB Home devices - TZ65D,TZ65S,TZ66D. Before updating openhab their type was correctly determined by openhab. But now all of this devices was appeared as TZ35S in inbox.

What is the difference between these devices?

Main difference is count of association groups:
TZ65S (as TZ35S) has group 1
whereas TZ65D has 3 association groups

I think my trouble related to TZ35S reporting as TZ65D

I also have a device ID 0808:0808

ii openhab2 2.5.0~S1608-1 all openhab2
ii openhab2-addons 2.5.0~S1608-1 all openhab2-addons

I can’t set addition channels.

I’m not really sure what to suggest. We would need to work out what the differences are, and try and work out why the devices are different in the database. Unfortunately manufacturers don’t tend to report exactly what devices have what IDs, so it’s up to users to try and report this information, and sometimes it’s incorrect. Sometimes manufacturers also supply devices with the same ID in different devices (I think TKB do this) and this makes it very difficult to differentiate devices (and is also non-compliant to the standards which requires devices to have unique IDs).

You said the difference is more association groups, but then also talk about not being able to set additional channels. Associations are not linked to channels in any way - ie more associations doesn’t relate to more, or less, channels. Channels are simply related to the user command classes and functionality of the device. I think we need to understand this first and then understand the real differences before we decide what to do.

How can I help in research? I can get any debug information.
This topic is very important to me.
I think I can assign actions to other channels using a very old version of the program.
But it is very uncomfortable.

Can you describe what you mean by this? If the channels aren’t in the latest version, then using an old version will not bring them back unless you only use the old version.

I’m just trying to understand what the issue is. Maybe you can provide a summary of the difference between the devices? If not I will try yo find some time in the next few days to compare the database.

With the TZ65D i have four association groups

group 1 = button 1
group 2 = button 2
group 3 = button 2 double click
group 4 i’m not use this

Group 1 Control:
If you associate a Z-Wave device into Group 1 , you can turn that device ON and OFF by tapping the top or bottom of the left switch once. The load attached to the TZ65D will also turn on or off. Associating nodes into Group 2 or 3 willcause a very slight delay before the command is transmitted to Group 1 nodes.
You can brighten the controlled device by pushing and holding the top of the left switch. Dim by pushing and holding the bottom
of the left switch.

Group 2 Control:
If you associate a Z-Wave device into Group 2 , you can turn that device ON and OFF by tapping the top or bottom of the right switch. You can brighten or dim devices by pushing and holding the top of the right switch. Dim by pushing and holding the bottom of the right switch. The load attached to the TZ65D is not affected. The LED on the righ switch will indicate the status of Group 2. Group 2 will be polled at a specific interval and the LED on the right switch will indicate the status of Group 2. The polling interval can be configured.

Group 3 Control:
If you associate a Z-Wave device into Group 3, you can turn that device ON or OFF by tapping the top or bottom of the right switch twice. You can bright en or dim devices by tapping the switch once then push and hold the top or bottom of the right switch. The load attached to the TZ65D is not affected.

Group 4 Control:
If you associate a Z-Wave device into Group 4, that device will be commanded to turn on or off when the TZ65D is commanded to turn on or off. Caution: The TZ65D will not transmit to Z-Wave devices in Group 4 if it is already in the state that the Z-Wave command commanded it to.
You can associate up to 5 Z-Wave devices into each of these groups.


As mentioned above, the association groups are not the same as channels. While association groups may be used to configure what messages are sent, it’s the channels that matter, and these relate to the actual commands that are sent from the device, to the gateway.

What I’m interested in is the CHANNELS at the moment since this defines the functionality of the device.

I meant setting up association groups from the old version of the OH.

About channels
One controlled device can be connected directly to a switch( TZ66D) or dimmer(TZ65D).
We can manage it through the “channel” property of OH.

button 2 can control only remote devices using association groups

physical wiring of the versions with one(TZ65/66S) and two buttons (TZ65/66D) are the same

L: Line voltage input
L’: Switched load output
N: Line neutral
3: Auxiliary switch signal input

Isn’t the problem with the TZ35? Don’t we need to understand the difference between the TZ35 which is currently using the IDs that you say your other device has, and the other device?

Maybe I’ll see if I can find some time over the next few days to try and work this out.

The problem is that I can’t use the second dimmer button. Two groups can be assigned to it (group 2 - one click, group 3 - double click).

Almost all my dimmers do not have a directly connected load.
I use z-wave dimmable lamps (Domitech Smart LED ) and control it through association groups

I expect to see the setting of the other association groups (group 2, group 3, group 4 ).

But what matters is not so much the groups - but the COMMANDS that are sent. Groups are simply a configuration setting. We need to know the command classes that are used to send commands between the device and the gateway.

I will try and find time to work this out from the database. Ultimately though we are stuck - either we fix your issue and break it for someone else, or we leave it alone. Ideally we’d try and get feedback from others with these devices so we can understand where the error really is.

The switch sends commands to devices(Domitech Smart LED ) using a z-wave without OH. I can’t setup it using one assotiation group.

The problem has appeared with this update TZ35S reporting as TZ65D . I have already suffered. I reported a problem a few months ago. Please roll back the changes. I think if were more association groups to set up this it would not be a problem. The problem appears when the association group is only one

Hi @chris. What do you think about my problem?

you did not help me at all

I tried to install earlier versions of OpenHub. In version 2.2, the type of my z-wave switches is determined correctly (TZ65D Dual Paddle Wall Dimmer). And I can do all the necessary settings.

Starting with the version 2.3 my devices are not detected correctly.

You have an error in the device database and there is no solution for working with my devices.

I think this manufacturer has reused device codes that causes this sort of problem.

Maybe this is linked -:

You are right, many models are produced with one identifier:

These are two-button switches and one-button switches. It is better to assume that the switch as a two-button.

This will allow setting more configuration parameters such as four associative groups.

Both are bad and will cause problems for someone - either someone doesn’t have a channel, or someone will have errors with their network due to incorrect definitions.

Basically, this incorrect definition makes things pretty difficult unless there is some other way to differentiate these devices - currently that is the firmware version, device type and device id.

In the current state of the database, having the latest version of OpenHub, how can I configure the associative group 2, 3 or 4?

If these groups are not in the database, then it is not possible to do this via OH unfortunately.

@chris if you add this device as TZ35D
then users of TZ35S can configure group 1
and users of TZ35D can set up groups 1-4
and we will all see 4 groups in the settings, which is a bit incorrect for the one-button version users
Tell me if I’m wrong.