[SOLVED] Total timeout 1000 ms elapsed after Update to OH2.4

http
Tags: #<Tag:0x00007fe054c453b0>

(Michael) #1

I’m running OH2.4 on Debian Linux (Upgrade with apt-get), have cleared the cache etc. so that all errors except this one are gone (at the moment):

[ERROR] [.smarthome.model.script.actions.HTTP] - Fatal transport error: java.util.concurrent.TimeoutException: Total timeout 1000 ms elapsed

I use the http-Binding with a 30000 ms timeout via http.cfg and don’t know why this error comes with this rule:

stvRequest = “https://user:pwd@home.myopenhab.org:443/rest/items/switch
sendHttpPostRequest(stvRequest, “text/plain”, “ON”)

I also tried to catch the timeout with several catch-versions but i wasn’t able to catch this too.
try{
sendHttpPostRequest(stvRequest, “text/plain”, “ON”)
}
catch(Throwable t){
logInfo(“Fehler”, stvRequest)
}

How can i set the timeout bigger, how can i catch the timeout and what could the timeout caused by? At the moment i this error everytime but home.myopenhab.org is reachable and my internet is up.

Best regards

Michael


(Vincent Regaud) #2

First, please use the code fences

I know it is not documented but have you tried:

stvRequest = "https://user:pwd@home.myopenhab.org:443/rest/items/switch"
sendHttpPostRequest(stvRequest, "text/plain", "ON", 5000)

PS: I have not idea if it will work or not…


(Michael) #3

Dear Vincent,

sendHttpPostRequest(stvRequest, "text/plain", "ON", 5000)

works in that way that the switch was set and i didn’t an error. If it changes the timeout vom 1000 to 5000 ms we will see in the future.

Thank you very much.

Best regards

Michael


(Vincent Regaud) #4

That’s what the 5000 is, the time out.
It’s not in the docs though.


(Vincent Regaud) #5

Please tick the solution, thanks