[SOLVED] Trådfri outlet support

Bought one of the new IKEA Trådfri outlets today to test. The few minutes I have had it, it seems to work fine except that it is not supported by openHAB. Is there any way I can help so that the outlets will be added to the Trådfri binding or is that work already on its way?
Unfortunately I did not get ahold of the wall switch, they where all sold out.


Hi Edward,

Nice. It depends on the OH2 version which you currently use in your system. It should work in the latest snapshot or OH2.4 milestone build:

Thanks, missed that totally :slight_smile:
Is it possible to run 2.4 bindings in 2.3?

Yes, it is. See manual add-on installation. But I am afraid you - or someone else - have to build it from the sources.

1 Like

Ok, great. Thanks for all the quick responses. Just started working with eclipse and java so perhaps… or I’ll have to wait until I upgrade. Now I know that it is doable atleast.

Hi Edward,

Good news. I just got the information that you can download the different binding versions from https://openhab.jfrog.io/openhab/libs-milestone-local/org/eclipse/smarthome/binding/org.eclipse.smarthome.binding.tradfri/.

Good luck.

1 Like

HI Christoph

Great, thanks for the information, have tried to build it myself but it keeps failing so this will save me a couple of hours.

Made me happy for a while, unfortunately karaf complains about dependencies: Unresolved requirement: Import-Package: org.eclipse.californium.core, tried to install the californium.core files I could locate but only got other errors instead. Any ideas?

Log into the Karaf console and try to install the missing feature:

feature:install openhab-transport-coap

Thanks once again, both for the answer and how fast you answered. Will try tonight or when I can login on my server again.

Now I think I have managed to add the latest Trådfri-binding, in karaf it says:

269 │ Active   │  80 │ 0.10.0.oh240M4         │ Eclipse SmartHome TRÅDFRI Binding

and in paperUI i get a new ON/OFF switch. Unfortunately the switch has no channels when I open up the thing. All it says is that it is online. I had som trouble with the installation so not sure if that might have caused it. All other Trådfri things works as before.

What about your logs? Do you see anything in there? May I ask you to enable DEBUG log for the TRADFRI binding and look what is happening?

Have to learn a bit more on how to enable logs for bindings, have’t really had the time since I migrated from 1.x

However, i got the following in the openhab.log:

2018-09-27 11:44:11.464 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'tradfri:0010:gwa0cc2bf86a87:65591' to inbox.
2018-09-27 11:44:39.481 [WARN ] [ore.internal.thing.ThingTypeResource] - Cannot find channel type: system:power
2018-09-27 11:44:47.518 [WARN ] [re.thing.internal.ThingFactoryHelper] - Could not create channel 'power' for thing type 'tradfri:0010:gwa0cc2bf86a87:65591', because channel type 'system:power' could not be found.```

I see. That is the culprit. The implementation uses one if the the new system default channel types which are not available in OH2.3. I am afraid there is no chance to get it running for you without upgrading your system to at least OH2.4 milestone 3. Sorry for the circumstances.

Hi Christoph!
Nothing to be sorry about it is as it is and I am really grateful for the fast responses and all the help you have given me with this. Now I know I have to wait until I go up to 2.4, unfortunately that might take a while since I am also depending on the Tellstick binding but that is another matter.

Once again, thank you for all help

You are welcome.

UPDATE: Fixed it - You need to remove/re-add the thing for it to get the default channel :slight_smile: Works now thanks :slight_smile:

I follow this thread with much interest, and since I’m in the same situations I decided to actually upgrade to 2.4.0 M4-1 (from Testing relaease on Ubuntu 18.04).

I can add the Tradfri 2.4.0 M4 Binding from within PaperUI, and I can add/connect to my Tradfri Gateway and also add my Power Outlets as Things without problems :slight_smile:

BUT, since the Power Outlet Thing doesent have any Channels, I dont know HOW to add and use it as an Item. (I usually add Items by editing my config files in /etc/openhab2/items).

Any suggestions would be very much appreciated :slight_smile:

Kalle Larsson

There is a workaround for those who are on OH 2.3.0 and currently don’t want to upgrade to OH 2.4.0 M4-1.
I got the outlets working by manually adding a thing type 0100 (Dimmable Light) instead of the upcoming thing type 0010, which will come with OH 2.4.0 M4-1.

Here is my configuration:
(OH 2.3.0) things:

Bridge tradfri:gateway:MyTradfriGateway "Bridge Ikea Tradfri" @ "ControlRoom" [ host="192.168.xx.yyy", code="MyCode" ] {
  Thing 0820 65550 "Outlet Tradfri RemoteControl" @ "Kitchen" [ id=65550 ]
  Thing 0100 65551 "Outlet Tradfri"               @ "Kitchen" [ id=65551 ]

(OH 2.3.0) items:

Dimmer OutletTradfri_Switch     "Outlet Tradfri"                       <poweroutlet> { channel="tradfri:0100:MyTradfriGateway:65551:brightness" }
Number OutletTradfri_Battery    "Outlet Tradfri RemoteControl [%d %%]" <battery>     { channel="tradfri:0820:MyTradfriGateway:65550:battery_level" }
Switch OutletTradfri_BatteryLow "Outlet Tradfri RemoteControl [%s]"    <battery>     { channel="tradfri:0820:MyTradfriGateway:65550:battery_low" }

(OH 2.3.0) sitemap:

Switch item=OutletTradfri_Switch

Of course this workaround needs to be changed after upgrading to OH 2.4.0 M4-1 or later:

  1. change thing type from 0100 to 0010
  2. check if Switch item instead of Dimmer item will be needed
  3. change channel from “:brightness” to “:power” or whatever the new channel will be named
1 Like

Hi all,
I am looking to purchase this bulb:

Would it talk to the HUSBZB-1 USB Hub? Or would I need IKEA ’ s controller too?