[SOLVED] Trouble with 2.3.0

Hi All,

I was running 2.2 without troubles. So i decided to upgrade to 2.3. 2.3 worked fine with the exception of Habpanel which was giving an error “Connection lost! Trying to reconnect…” 95% of the time. I tried everything including removing all the configurations (items, things, and scripts) and uninstalling the handful of bindings I use. Nothing worked.

So I opted to blow away the entire openhab folder (i install from scratch, no package) and start again with a fresh 2.3 (with none of my old configurations). I then noticed was that ALL bindings were installed and running which made things ridiculously slow. At this point I switched to Zulu. I also noticed that no matter what I did, the demo files kept getting created (i have never been in demo mode, and tried to change conf/services/addons.cfg with no luck).

Then i tried to uninstall the bindings one by one using habmin and/or paperui, however, this didn’t work, it would just spin and spin.
So i hopped over to karaf and tried to uninstall the bindings from there:

bundle:stop ID 
bundle:uninstall ID

This didn’t give an errors, but it had no impact on habmin and paperui. They still show they were installed.

I then ran a script to uninstall ALL bindings (300+), which broke everything obviously, then blew away my openhab folder and did a fresh install of 2.3.0. As soon as it starts up (even if i select “simple” or “expert” or “skip”) it get an unusable system with everything on.

I simply can’t get a fresh install without a zillion bindings starting up and completely slowing down my system to a crawl.

I am at a loss as to how i get a clean 2.3 install with only the minimum bindings installed.

The script I use to install:


  cd $BASE
  mkdir openhab-${VER}/
  cd openhab-${VER}/
  wget -O openhab-${VER}.tar.gz "https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab%2F${VER}%2Fopenhab-${VER}.tar.gz"
  tar xvfz openhab-${VER}.tar.gz
  rm openhab-${VER}.tar.gz
  cd $BASE/openhab-${VER}/addons/
  wget -O openhab-addons-${VER}.kar "https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab-addons%2F${VER}%2Fopenhab-addons-${VER}.kar"
  wget -O openhab-addons-legacy-${VER}.kar "https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab-addons-legacy%2F${VER}%2Fopenhab-addons-legacy-${VER}.kar"
  cd $BASE/openhab/openhab-${VER}/
  rm -rf $BASE/openhab-${VER}/userdata/logs
  rm -rf $BASE/openhab-${VER}/logs
  ln -s /var/log/openhab $BASE/openhab-${VER}/userdata/logs
  ln -s /var/log/openhab $BASE/openhab-${VER}/logs


What OS are you using?

Ubuntu Artful

[root@openhab ~]$ java -version
openjdk version “1.8.0_181”
OpenJDK Runtime Environment (Zulu (build 1.8.0_181-b02)
OpenJDK 64-Bit Server VM (Zulu (build 25.181-b02, mixed mode)

[root@openhab ~]$ uname -a
Linux openhab 4.13.0-43-generic #48-Ubuntu SMP Wed May 16 12:18:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Why don’t you try the package installation instead?

Its seems like deleting the userdata/cache/* and userdata/tmp/* were causing the many bindings to turn on. I have now got them all off (except the ones i want) and its more responsive.