[SOLVED] Unable to connect to 8080 after Openhabian Java Update (OpenHab 2.5.2 Java

After performing a system update using openhab-config, I am unable to connect to :8080. The process seems to be running correctly, and I cannot find any errors in openhab logs.

Any help would be greatly appreciated.

Nothing in openhab2.log or events.log?

nothing, all I see are the shutting down entries prior to the upgrade.

If you go into the karaf console, and check the status of the bindings are they all running?


I get connection refused when trying to connect to karaf console.


From the command line try: sudo openhab-cli console

Failed to get the session


Stop OH, clean the cache and reboot. After the reboot has finished then restart OH a few times and see if that helps.

BTW, what are you running OH on and how did you install it?

Use journalctl to look for startup errors?


Up and running now :slight_smile:

I am running the latest Openhabian on Raspberry Pi 4.

Thanks so much.


Glad it worked. :+1:

@falco_07 Please click the square box on the post that provided the solution to mark the topic as solved.