SOLVED: Unable to Connect to MyOpenHAB Dashboard, but everything else seems to working

I am planning a trip and thought it would be good to have fallback access to OpenHAB, even though I am running a VPN. I was able to log on to and I am ONLINE and able to receive Notifications without any problem, however if I try to access the Dashboard I get an error message “openHAB connection error: HttpClient@6a747391{FAILED} is stopped”

My OPenHAB Cloud has the Mode Setting as Notifications & Remote Access. In the past running 2.4 I was able to use this service without issue, but haven’t tried with 2.5.1 Docker until now. I did try uninstall and reinstall the OpenCloud Connector, but that didn’t seem to help. Is this a known issue that I missed or is it unique to me? Any suggestions as to where I might begin? I didn’t intentionally change anything, but in the upgrade I might have done something I didn’t intend.

UPDATE: I deleted my account, UUID and secret, reinstalled Cloud Connector, created a new account and now I am seen as OFFLINE. No Notifications, Items or Dashboards.

UPDATE 2:After a lot of thrashing I was able to reconnect to the Cloud Connector, devices are seen and notifications are working again, however still no luck in getting the Dashboard to load. I find it hard to believe I am the only one with this issue, but for now I live with it.

SOLVED: I was able to find a fix to this problem. In addition to upgrading to 2.5.1 I also had a hardware upgrade to a 12 core 24 thread enterprise type server. Apparently OpenHAB/Jetty does not accommodate this many threads very well. By pinning OpenHAB to use only 4 Threads or increasing the number of available threads in the runtime.cfg I am now able to connect to the Dashboard via the Cloud Connector without any issues. I found this solution in post from @mhilbush “Fix for Jetty error when running on host with many cores”

1 Like