[Solved] Unable to install using apt-get. Getting 405 Not Allowed when updating

I’m trying to follow the instructions found here:

And I run into and issue when trying ‘sudo apt-get update’ I see this:
W: Failed to fetch http://dl.bintray.com/openhab/apt-repo2/dists/stable/main/binary-armhf/Packages 405 Not Allowed

If I go directly to that URL, I can download the package with no problem.

I’m using a brand new Raspian Jessie image that I downloaded today (05/12/2017).

I’m stuck at this point. Any ideas?

Thanks in advance!

I believe that we may need to open up an issue for this one.
I was able to replicate this as well in my test rPi3 system with Raspbian. I get the same error.

@Kai @Benjy

Try snapshot for now :slight_smile: (or do a manual install of 2.0.0 with the tar.gz from Bintray)
Thanx for reporting this !

I’ll have a look, shouldn’t have changed but if necessary I’ll put it back on.

Hi all, it seems that Bintray does not support the HTTP protocol with apt-get anymore. I will edit the docs to reflect this change:

You may install using the following commands:

sudo apt-get install apt-transport-https 
echo 'deb https://dl.bintray.com/openhab/apt-repo2 stable main' | sudo tee /etc/apt/sources.list.d/openhab2.list
sudo apt-get update
sudo apt-get install openhab2

This worked, thank you!!

Alternatively you can simply change the URL in /etc/apt/sources.list.d/openhab2.list from http to https


I am getting the same error on openhabian now. The fixes above did not help. Opening the url directly gives a “forbidden”-response.

Any ideas?

Regards, SM

Looks like we’re having issues with out Bintray account. @Kai, any ideas why it’s been “limited”?

me too

Err:1 https://dl.bintray.com/openhab/apt-repo2 stable/main armhf openhab2-addons all 2.2.0-1
403 Forbidden
Err:2 https://dl.bintray.com/openhab/apt-repo2 stable/main armhf openhab2-addons-legacy all 2.2.0-1
403 Forbidden
E: Failed to fetch https://dl.bintray.com/openhab/apt-repo2/pool/main/2.2.0/openhab2-addons_2.2.0-1_all.deb 403 Forbidden
E: Failed to fetch https://dl.bintray.com/openhab/apt-repo2/pool/main/2.2.0/openhab2-addons-legacy_2.2.0-1_all.deb 403 Forbidden
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

No, I just received an automatic notification from bintray saying that they “rate-limited” our account due to “overuse”. I contacted their support and asked for details. Seems openHAB became too popular :roll_eyes:.


Works now again. Thanks Kai,

HNY 2018!

1 Like