[SOLVED] Unknown Device - Neo Coolcam Motion Sensor(PIR)

I have problem with-I think-identify of device:

NODE 11: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

More of the log file:
https://drive.google.com/file/d/1Tkc-5zVcTithfmNa7fiX7TgoGbiNoM1b/view?usp=sharing

I tried to remove and include again this device, and also remove, restore defaults and include again. Still the same situation. What can I do?

1 Like

This means that the device has not been discovered fully yet. The 7FFFFFFF means that the information has not been downloaded from the device, and therefore it can not tell what type of device this is.

As this is a battery device, it will be sleeping, and you need to wake the device up to allow the interrogation sequence to complete. Check the manual to see how to do this for the device you have.

I did wakeup through the sensor button many times and situation never changed. This sensor is in this state for a weeks… Is there anything what can I do more?

What are the debug logs showing? Does the binding actually receive the wakeup messages? If not, maybe it’s not included correctly, or maybe it’s out of range.

The debug log should be inspected to find out what is happening though.

Maybe I can help at this issue. The problem with the neo motion sensors is, that even woken up ones dont necessarily send the frame. I dont know why, but I had a similar issue and had to remove the batterie several times and wake it up parrallel. Another try is, to reset the device by holding the button for at least 10s. Then push the button again three times to send the frame. Hopefully that helps otherwise the device is broken. I had a broken neo window sensor with an issue on the electic board, which couldnt be recognized as well. Later the dealer gave me the feedback, that the antenna was the problem.

1 Like

Thanks oeo! I had to push the motion sensor button three times instead of one. After first 3x push I saw that something good is happening in openhab logs and second 3x did the discover process finally complete.

I don’t understand that in context of instruction manual. It was mentioned about one press to wake up device. Three times only when we want to include device to z-wave network or exclude.

Once again thanks for help :slight_smile:

1 Like

You`re welcome.:wink: Just sign my answer as solution, so that its easier for people with same issue to find the answer.

Chris,
I just got one of these, and it seems they are using a difference device reference for them, so it’s showing as Unknown.

This is the device :
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/401

and the Type;ID that I have is : 0003:008d

Any chance that can be added in the database?

I’ve added this reference. Please can you check that the parameters are the same as in the manual for your device.

I’ll do a database update tomorrow so it should be available after that.

They are the same. Thank you,

Hi,

My problem might be related to this thread. I have just received the following unit:

http://www.szneo.com/en/products/show.php?id=213

My setup is:
Latest stable OpenHab 2.3 deployed on Raspberry Pi with Aoetec z-stick.

I have tried to add this device to things many times through various sequences of 3xpush, 1x push, reset, power off and power on, inclusion, exclusion. It is always detected as unknown device with increasing node number after resets. Paper UI shows following properties:

zwave_class_basic	ROUTING_SLAVE
zwave_class_generic	SENSOR_NOTIFICATION
zwave_frequent	false
zwave_neighbours	
zwave_nodeid	8
zwave_version	0.0
zwave_listening	false
zwave_routing	true
zwave_plus_devicetype	UNKNOWN_TYPE
zwave_beaming	true
zwave_class_specific	NOTIFICATION_SENSOR

I have gathered following logs:

Latest node number was NODE 8. Unfortunately as you can see logs like this:

2018-07-14 22:00:55.034 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 8: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

I belive that following log is the result of 1x push (wake) after adding unknow device. I am not an expert but it could look optimistic. Nevertheless PaperUI still shows that NODE 8 is unknown.

2018-07-14 22:01:31.520 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: MANUFACTURER not set
2018-07-14 22:01:31.525 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Controller status changed to ONLINE.
2018-07-14 22:01:31.532 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Controller is ONLINE. Starting device initialisation.
2018-07-14 22:01:31.579 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Updating node properties.
2018-07-14 22:01:31.586 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Updating node properties. MAN=2147483647
2018-07-14 22:01:31.593 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Properties synchronised
2018-07-14 22:01:31.615 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Property to update: wakeup_node, 0, null
2018-07-14 22:01:31.620 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Properties synchronised
2018-07-14 22:01:31.636 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Initialising Thing Node...
2018-07-14 22:01:31.639 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Polling intialised at 1800 seconds - start in 1800000 milliseconds.

Any suggestions how to proceed?

Kind Regards

It doesn’t look like this has woken the device. Unless the device sends a specific “wake up” command to the binding, the binding can not communicate with the device.

Check the manual for how to wake the device up.

Manual clearly indicates that wakeup notification can be send by pressing button once. I did this many times after adding unknown device to the things. Strange thing is that after attempting to add this unit to the network at lest 3 other units are now offline (dead). This has never happened before. I will try to solve this issue and then I will get back to PIR sensor.

OK I have removed dead nodes and I trying to add this sensor. Situation is more or less the same. It adds as undefined device. After that when I push button only once no debug messages are shown. Power off/on generates following log:

13:18:34.876 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 0C 00 04 04 09 06 31 05 03 0A 00 0D CC
13:18:34.881 [DEBUG] [ave.internal.protocol.ZWaveController] - Receive queue TAKE: Length=0
13:18:34.886 [DEBUG] [zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 0C 00 04 04 09 06 31 05 03 0A 00 0D CC
13:18:34.891 [DEBUG] [ave.internal.protocol.ZWaveController] - Process Message = 01 0C 00 04 04 09 06 31 05 03 0A 00 0D CC
13:18:34.896 [DEBUG] [ave.internal.protocol.ZWaveController] - Message: class=ApplicationCommandHandler[0x04], type=Request[0x00], priority=High, dest=255, callback=0, payload=04 09 06 31 05 03 0A 00 0D
13:18:34.901 [DEBUG] [essage.ApplicationCommandMessageClass] - NODE 9: Application Command Request (ALIVE:MANUFACTURER)
13:18:34.906 [DEBUG] [essage.ApplicationCommandMessageClass] - NODE 9: Incoming command class SENSOR_MULTILEVEL
13:18:34.910 [DEBUG] [ass.ZWaveMultiLevelSensorCommandClass] - NODE 9: Received COMMAND_CLASS_SENSOR_MULTILEVEL command V0
13:18:34.914 [DEBUG] [ass.ZWaveMultiLevelSensorCommandClass] - NODE 9: Sensor Multi Level REPORT received
13:18:34.919 [DEBUG] [ass.ZWaveMultiLevelSensorCommandClass] - NODE 9: Sensor Type = Luminance(3), Scale = 1
13:18:34.923 [DEBUG] [ass.ZWaveMultiLevelSensorCommandClass] - NODE 9: Sensor Value = 13
13:18:34.927 [DEBUG] [ave.internal.protocol.ZWaveController] - Notifying event listeners: ZWaveMultiLevelSensorValueEvent
13:18:34.932 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 9: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent
13:18:34.936 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 9: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 13

Then pushing button 3 times generates following log:

Any suggestions?

KInd Regards

From this log, it looks like initialisation is complete, but as the manufacturer information is one of the first things done in the initialisation, it’s not shown in this log - you need to provide the log from a little earlier so I can confirm.

Log from the inclusion sequence:

Before that I have excluded device from network. After such inclusion Paper UI still shows that device is unknown.

This log doesn’t seem to be linked to the previous log. I’ve got two halves at different times, on different nodes, and they don’t really join up. The previous one completed the initialisation and looked fine. This one is just the inclusion - no initialisation and no wakeup (and hence no initialisation)…

Please can you provide the earlier log, but complete. Or a new log, but complete. Don’t forget to wake the device up during the initialisation.

Indeed those were different attempts. I finally managed to include it properly. Below you can find the log.

The only difference in the process was that I pushed 3 times button to wake it up after it was added as unknown device. This is rather against the manual but it worked. Quite painful process but thank you for your support.

I had some difficulties with my Neo Coolcam PIR as well.
But second try I pushed the “awake” button quite a few times, again and again. After a minute or something, it was included 100%.

I do however have some problems doing config changes to it afterwards.

You’re welcome. I know ZWave battery devices are not the easiest to use - they have quite a painful operation concept…

I’ll update the database at least, so it’s documented somewhere. This will flow into the OH documentation for this device

Note that you need to either wake up the device, or wait for it to wake up by itself. It seems that by default this device only wakes every 12 hours (from the log from @mmspock), so unless this is set to a lower value (which may impact the battery) you will need to wait a while for configuration changes to take effect.

The alternative is to wake it manually after making configuration changes.