[SOLVED] Unknown Zwave device not yet in the databse

Hello! I hope this is the right place to post this but it seems i have gotten a z-wave device that is not in the database and i am wondering how i can help for it to be added.

I am running Openhab Stable 2.4 on a RPi 3b.

It is a NEO Coolcam power plug, i already have two of these that work without issues.

Info from the thing properties:

Z-Wave Node 020 (0258:0200:1027:2.21)

zwave_beaming true
zwave_class_basic BASIC_TYPE_ROUTING_SLAVE
zwave_class_generic GENERIC_TYPE_SWITCH_BINARY
zwave_deviceid 4135
zwave_devicetype 512
zwave_frequent false
zwave_listening true
zwave_manufacturer 600
zwave_nodeid 20
zwave_plus_devicetype NODE_TYPE_ZWAVEPLUS_NODE
zwave_plus_roletype ROLE_TYPE_SLAVE_ALWAYS_ON
zwave_routing true
zwave_secure false
zwave_version 2.21

If there is any more information that i can provide please let me know.

It is here:


Please upgrade to the latest zwave snapshot binding.


This script make it easier to upgrade the binding.

1 Like

Thank you sihui and Bruce_Osborne , i’ll give this a try tomorrow morning!

Thanks again to both of you! Updating the binding did the trick and that script helped getting it done quickly, only one issue with the script was that it would time out during uninstallation of the current zwave binding but uninstalling it manually as suggested in the posted issue on github did the trick. The power plug works now as intended. Will update to OH2.5 once stable is released.