[SOLVED] Unresponsive Z-Wave Network: Tools and Approaches to track down the issues

Converting the zstick to a Zniffer (if you have not done that already) will help in repeater replacement. I have found that what I “think” is a good location was not actually. Radio communications are tricky.

Yes Stefan, I referred Andrew to this thread because he was having trouble with exactly that. This is a great resource for folks having trouble with zwave, thanks for posting and sorry to clutter up the thread

nice, that will work as well :+1:

1 Like

great idea Bob repost your link to instructions in post number 2 above

Fyi, I have added the zwave sniffer link to the top of the thread to find it easier.next time.

3 Likes

I just want to chime in with my recent experiences regarding this issue. (Aeotec Gen5 stick)
It also concludes that any zombie/dead nodes not properly removed on the controller stick, can come back to haunt you and make trouble a long time afterwards.

In my case, I just physically removed 3 AC powered nodes without removing them from the controller. (Lazy me!). All seemed well, and my network worked as before for months.

Then, all of a sudden, my network started to act up.
The most visible clue, except for non functional nodes, was that the colored LED on the stick stopped blinking. (well not actually stopping, but switching color once every 5 min instead of every second.) This is the same as @stefan.hoehn 's experience that messages could take a very long time to get through.

Time to fire up Zensys on my WinPC.
There I noticed the same phenomenon.
Each time I selected a zombie node in and tried sending a NOP to it, the LED blinking halted.
The NOP operation failed, and no matter how many times I tried to mark it Inoperable and remove it, no cigar.
Must have tried 10-20 times with Zensys restart and stich un/re-plug every time.
My biggest mistake at this point, was that I had thrown away (in the trash) 2 of the 3 nodes giving me this trouble, so I could not fire them up and do the prober removal procedure.
At this point I was dreading that I had to wipe the stick and re-include all my 50+ nodes.

Only one possibility left for me. I plugged in my second Aeotec Gen5 stick where I keep a cloned copy. I had of course tried this stick earlier after my problems started and it showed exactly the same behavior. LED blinking halting 1-2min after a OH3 reboot.
To my delight I was able to delete the zombies of the 2 discarded nodes, but got the same problem with a third node, but luckily, I still had this node in a drawer. After powering it up, it was seen be the stick/Zensys and I could remove it the normal way. Puh.

The new content of my stick was backed up, and restored to my second stick. I was home dry.
My network was performing well again. LED doing a merry multi-colored blinking every second or so.

Lessons learned:

  • never, ever just physically remove z-wave nodes
  • never, ever throw away nodes not properly removed
  • invest in a second stick for backup. Turned out that restoring the PROM content acted differently on two different sticks. On one accessing 2 of 3 nodes caused it to hang, and the other on the third. Felt like something in the routing table persisted in the battery backed RAM on the stick, survived even a factory reset.
  • for Zensys users not able to get the checkmark in step 2, that is normal for frequently listening nodes. (ie non.battery nodes)

So guys (and girls), be safe, not sorry; back up to a second stick. :slight_smile:

I still wonder if it had been possible to remove the nodes that failed the Zensys NOP (which timed out) procedure some other way? Maybe if the Zensys NOP timeout had been much much longer?

I usually just tell the SiLabs PC Controller software to remove the node from the controller. Never hadthat fail yet.

Befior ethat, I did similar with the older Zensys Tools, I believe.

I do not have Aeotec sticks though.

Did you mean “Check if failed” or NOP? I use the “check if failed” and if the node is in a drawer, it turns red and then use “delete failed”.

Agree with a second stick idea.

Bob

Bruce, do you mind explaining in a detailed way how to exactly use the silicon lab tools to remove a node as I am not familiar with it?

PC Controller is part of the Controller Software Development Kit available as a free download.

2 Likes

In my case the NOP operation failed with a timed out error message.
No matter what I tried resolved it.
As soon as I hit Send NOP, the LED on the controller stopped blinking and the communication with the stick broke down.
Had to un/re plug stick and restart Zensys for each try.

I will give this a try the next time I need to clean up my mess. :slight_smile:

Are you gonna check this out and maybe update the How-To ?

I thought someone with experience could actually document how to do this as I have no experience with the PC controller and haven’t got the time to train myself on that at the moment based on the manual provided :innocent:

Sure, I am happy to update the doc at the beginning if anyone guides my how it is done with silabs PC controller.

You caught me in a good mood :smiley: Especially for you.

Z-Wave Zombies.pdf (571.9 KB)

2 Likes

I was able to register as a Company Private and could download the SimplicityStudio-5.iso. (~500MB)
After the install, which took some 20 minutes, I found the Z-Wave PC-controller in the Tools section. :slight_smile:

1 Like

Your simply the best…! :musical_score::pray:

Interestingly there was also a Z-wave sniffer tool there as well. Will check it out after my vacation. No z-wave where I’m at now. :relaxed:

I think you will see less of me as I move elsewhere. I had a test controller I needed to clean down anyway.

It’s been a while now, so I thought I’d add a quick note on status and progress etc…

Since using the tools and removing the nodes that were dead or playing up my z-wave network has been solid… no errors and reliable.

Thanks again for all the helps.

3 Likes