[SOLVED] Unresponsive Z-Wave Network: Tools and Approaches to track down the issues

You are correct.

232 is max and then any unused id are assigned starting with the lowest id.
.

As you only have one node do a hard reset which will remove all nodes and start a new network. The home id will change and the next node you add will be 2. Remove node 6 first so it is ready to add to the new network.

Add your nodes working out from the controller by distance so low id are nearest the controller. Z-wave routing works best in networks built this way.

Thanks @Andrew_Rowe for pointing me at this @stefan.hoehn post.

After weeks of digging I think I have located 3 problem z-wave nodes (at least)… 2 are Fibaro sensors, outside in waterproof boxes, both have had water get in and are totally dead. the third is a Fibaro dimmer which I thought I had removed ages ago but is still showing up on the z-stick. The module is definitely not connected any more.

I have downloaded the latest zensys z-wave pc controller tool and plugged my Aeotec z-stick into the PC. I could not find any “Queue Override” checkbox to toggle? I assume that was an older version?

I highlighted the first of the 3 nodes (the Fibaro dimmer) - I clicked the “is Failed” and it did a NOP and an Is Failed Node Check - telling me that the node status “is failed”. I clicked “Remove Failed” and it returned to say that “Remove Failed Node completed”. The Node seems to have gone from the list… All good I think :slight_smile:

But the 2 Fibaro sensor modules are a problem. Both are totally dead, so I can’t press the buttons to remove them etc. NOP fails to each as does Is Failed.

What to try/test next? Anyone have any ideas?

Over time helping people who report sluggish performance from a zwave system, it always turns out to be zombie nodes on the system… always… every time. Often, one offline node is enough to cause huge problems. I think you are on to the issue, can’t advice how to proceed as I haven’t used the pc controller tool but good job figuring it out so far and keep digging
Report back if you figure out how to remove the other two dead nodes and maybe somebody with experience using the software can jump in to help :+1:

2 Likes

So I literally tried everything… from both OH3 and from the zensys tools… Both removal and replacement routes… No idea what I changed or did, but suddenly the node responded positively and eventually got deleted… So I now seem to have a z-wave network with no new errors…

My concern now is the distance between the house and the garage nodes… especially with wet bushes… May need to try the 2 z-stick approach next… Still so many things to do… but I’m hoping it starts behaving reliably again now… fingers crossed :slight_smile:

Thanks for the help.

That is good news indeed!

Well, I’m sure you realize that mains powered nodes can act as repeaters and extend the mesh network’s range so maybe you have already strategically placed mains powered device between the two structures and it is just to much distance but if not give that some thought

me as well, but report back on that in a week or two

I had the same experience when trying to remove the nodes. Follow exactly what I wrote above. Sometimes what happens is that within the node list the node is still visible after trying to remove it, you you think the removal didn’t work. However, if you stop and start the tool and the node list is loaded again, almost 100% of the times, the node is actually gone.

With mine it reported errors every time and was still there after reloads etc… then after numerous attempts over a couple of days it reported success… Odd… You would have thought that in this day and age it would be possible to build a mesh network that routes around repeatedly unreliable nodes etc… :slight_smile:

Thanks.

I had a switch module strategically placed in an IP68 box but that’s one of the units that kept reporting disconnects, so I have removed it… see how I go without it… Don’t know if some units are better than others for that task…

I’ll either re-do the IP68 boxes or an IP66 mains socket higher up on a wall half way with a repeater plugged in. Or I’ll try to Share Z-wave dongle over IP (USB over IP using ser2net / socat ) guide… I have a spare z-stick and Pi3… and the garage is networked…

Thanks.

Are we on the same page that you are using zensys to remove the node? Removing via the openhab controller doesn’t work, you need to use the zensys tool to work on a lower level.

Converting the zstick to a Zniffer (if you have not done that already) will help in repeater replacement. I have found that what I “think” is a good location was not actually. Radio communications are tricky.

Yes Stefan, I referred Andrew to this thread because he was having trouble with exactly that. This is a great resource for folks having trouble with zwave, thanks for posting and sorry to clutter up the thread

nice, that will work as well :+1:

1 Like

great idea Bob repost your link to instructions in post number 2 above

Fyi, I have added the zwave sniffer link to the top of the thread to find it easier.next time.

3 Likes

I just want to chime in with my recent experiences regarding this issue. (Aeotec Gen5 stick)
It also concludes that any zombie/dead nodes not properly removed on the controller stick, can come back to haunt you and make trouble a long time afterwards.

In my case, I just physically removed 3 AC powered nodes without removing them from the controller. (Lazy me!). All seemed well, and my network worked as before for months.

Then, all of a sudden, my network started to act up.
The most visible clue, except for non functional nodes, was that the colored LED on the stick stopped blinking. (well not actually stopping, but switching color once every 5 min instead of every second.) This is the same as @stefan.hoehn 's experience that messages could take a very long time to get through.

Time to fire up Zensys on my WinPC.
There I noticed the same phenomenon.
Each time I selected a zombie node in and tried sending a NOP to it, the LED blinking halted.
The NOP operation failed, and no matter how many times I tried to mark it Inoperable and remove it, no cigar.
Must have tried 10-20 times with Zensys restart and stich un/re-plug every time.
My biggest mistake at this point, was that I had thrown away (in the trash) 2 of the 3 nodes giving me this trouble, so I could not fire them up and do the prober removal procedure.
At this point I was dreading that I had to wipe the stick and re-include all my 50+ nodes.

Only one possibility left for me. I plugged in my second Aeotec Gen5 stick where I keep a cloned copy. I had of course tried this stick earlier after my problems started and it showed exactly the same behavior. LED blinking halting 1-2min after a OH3 reboot.
To my delight I was able to delete the zombies of the 2 discarded nodes, but got the same problem with a third node, but luckily, I still had this node in a drawer. After powering it up, it was seen be the stick/Zensys and I could remove it the normal way. Puh.

The new content of my stick was backed up, and restored to my second stick. I was home dry.
My network was performing well again. LED doing a merry multi-colored blinking every second or so.

Lessons learned:

  • never, ever just physically remove z-wave nodes
  • never, ever throw away nodes not properly removed
  • invest in a second stick for backup. Turned out that restoring the PROM content acted differently on two different sticks. On one accessing 2 of 3 nodes caused it to hang, and the other on the third. Felt like something in the routing table persisted in the battery backed RAM on the stick, survived even a factory reset.
  • for Zensys users not able to get the checkmark in step 2, that is normal for frequently listening nodes. (ie non.battery nodes)

So guys (and girls), be safe, not sorry; back up to a second stick. :slight_smile:

I still wonder if it had been possible to remove the nodes that failed the Zensys NOP (which timed out) procedure some other way? Maybe if the Zensys NOP timeout had been much much longer?

I usually just tell the SiLabs PC Controller software to remove the node from the controller. Never hadthat fail yet.

Befior ethat, I did similar with the older Zensys Tools, I believe.

I do not have Aeotec sticks though.

Did you mean “Check if failed” or NOP? I use the “check if failed” and if the node is in a drawer, it turns red and then use “delete failed”.

Agree with a second stick idea.

Bob

Bruce, do you mind explaining in a detailed way how to exactly use the silicon lab tools to remove a node as I am not familiar with it?

PC Controller is part of the Controller Software Development Kit available as a free download.

1 Like

In my case the NOP operation failed with a timed out error message.
No matter what I tried resolved it.
As soon as I hit Send NOP, the LED on the controller stopped blinking and the communication with the stick broke down.
Had to un/re plug stick and restart Zensys for each try.