[SOLVED] Upcoming problem: Sitemap Webview and Grafana 5.4.0beta1

I’m on 2.5.0-SNAPSHOT Build #1498
Android openHAB APPs (release & beta) updated from Play Store today.
Both behave the same.

Webview that used to work in 5.1.0:

Frame { Webview height=10 url="http://<url>:3000/d-solo/54ytDxTmz/movements?panelId=2&orgId=1&theme=light"  }

Also tried:

Frame { Webview height=10 url="http://<url>:3000/d-solo/54ytDxTmz/movements?panelId=2&orgId=1&theme=light&width=380&heigth=190" }

Seems like Grafana don’t get the height parameter:

The two urls above work fine in Chrome

The document states the height comes after the url, and I have noticed that some elements of OpenHAB can be rather picky with the order of the parameters that are passed. So does it work if you switch height to come after url, or remove height altogether?

This might also be a grafana issue. The webview height is set correctly, otherwise you couldn’t see the error message.

I’ve experienced the same issue some while ago.
I’m on archlinux, the update to 5.4.0 broke the webviews.
I downgraded grafana at that time.
Now I’m on grafana 5.4.2 and all is well.
I have not took a deepdive into changelogs etc, so I’m not sure which versions brings the changes

@derkens what is your apt/sources list for getting that version?

With this:

$ cat /etc/apt/sources.list.d/grafana.list
deb https://packages.grafana.com/oss/deb beta main

I end up on 5.4.0beta1

I’m using archlinux, it is a rolling updates distribution, so I’m always on the latest version. Actually, 5.4.3 is the latest version, Probably it is still in the archlinux testing repo.
It shows on the grafana download page , I dont know how to get that version with apt.

OK, I will give it a try tonight.
So this is probably not an issue, since I was not on the latest version.

I changed my /etc/apt/sources.list.d/grafana.list from beta to stable and received the 5.4.3 version.
Tried the Android App and the Sitemap Webview worked fine.

Sorry for the buzz.