[SOLVED] Upgrade Grafana 5-->6 "Connection refused"

Today I upgraded from Grafana 5 to 6. I used the video GRAFANA in OPENHAB 2 deutsch / Influxdb / HABpanel / OPENHAB Tutorial to install Grafana. Today I learned this was an older version of Grafana. So I choose to upgrade Grafana on my raspberry, which also hosts openHAN and InfluxDB).
After upgrade

sudo apt-get install -y adduser libfontconfig1
wget https://dl.grafana.com/oss/release/grafana-rpi_6.5.3_armhf.deb
sudo dpkg -i grafana-rpi_6.5.3_armhf.deb

I logged on to Grafana: everything is OK :slight_smile:

BUT in openHAB I get the message “< my IP Adres> has refused the connection” (translated from Dutch).
When I scroll down in the upgrade instruction on https://grafana.com/docs/grafana/latest/installation/upgrading/ I see mentions of cookies and other ‘security stuff’. Frankly, I dont care, because I am using openHAB only on my home network.
My wife doesnt hack

Grafana upgrade prob

I guess/think that a setting in grafana.ini is bugging me.

When I copy the URL into the address bar of my browser, I do see graphs; only in openHAB I get this message.

Hope anybody can help me with this. Thx in advance !

In MS Edge I get the following message:

This content cannot be displayed in a frame
There is content, but the publisher does not allow it to be displayed in a frame. As a result, the data that you may enter on this site is better protected.

Started Grafana in debug mode. No clue found so far.
One line says

t=2020-01-23T17:35:54+0100 lvl=info msg=“Request Completed” logger=context userId=0 orgId=1 uname= method=GET path=/d-solo/nAW5-KWRz/zonnepanelen-opbrengst-per-dag-huidige-maand status=200 remote_addr=192.168.2.52 time_ms=12 size=25699 referer=“http://192.168.2.143:8080/basicui/app?sitemap=mysite

Status 200 seems OK. (my browser is 192.168.2.52, server is 196.168.2.143)

Cleared browser cache…no result

Found the solution :slight_smile:

sudo vi /etc/grafana/grafana.ini

(or use nano instead of vi )

Search for [security]

add the following:

allow_embedding = true

Source: https://grafana.com/docs/grafana/latest/installation/configuration/#allow-embedding

then restart grafana server daemon:

sudo systemctl restart grafana-server

Is it safe to say that updating Grafana to latest version is safe?
I am hesitating as openhabian-config does not provide that option (I am still on 5.1.4)

I have successfully upgraded Grafana, using my own comments.
It is running for some time now.
No issues over here ! :slight_smile: