[solved] /usr/share/firemotd/cache/firemotd-Gray.motd: No such file or directory

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue
    when I login via ssh I get the following error message

Linux openHABianPi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l
The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.
Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Jan 7 22:16:02 2019 from
2019-01-07 22:27:15,699: FireMotD: Warning: Cache for theme Gray not found in FireMotD cache folder. Generating…
touch: cannot touch ‘/usr/share/firemotd/cache/firemotd-Gray.motd’: Permission denied
chmod: cannot access ‘/usr/share/firemotd/cache/firemotd-Gray.motd’: No such file or directory
/opt/FireMotD/FireMotD: line 1602: /usr/share/firemotd/cache/firemotd-Gray.motd: Permission denied

I changed the permission to

[22:28:55] openhabian@openHABianPi : /usr/share/firemotd $ ls -l
insgesamt 16
drwxr-xr-x 2 openhab openhabian 4096 Jan 7 22:06 cache
drwxr-xr-x 2 openhab openhabian 4096 Jan 7 22:14 data

I run openhabian-config and updated firemotd - same result.

No idea how to fix it

Thanks for help

Same environment, same behavior, same result. Also I do not know what to do further on.

I have same issue after installing 2.4 on fresh image of openhabian.

I had to execute

sudo /opt/FireMotD/FireMotD -I -v


-I is for ‘install mode’, -v is ‘be verbose’

1 Like

Dear Udo,
thanks, but the following code worked in Oct with OH 2.3.0-1 stable:

cd /opt/FireMotD
sudo ./FireMotD -I -v

but not now. I tried this code again, but the failure does not disappear!

@Udo_Hartmann Let me try that again. I ran that once and it removed the original error. Then this one appeared. I Will try it again.

Here’s what I did and it seems to have worked:

cd /opt/FireMotD
sudo ./FireMotD -TF /opt/FireMotD/themes/FireMotD-theme-Gray.json
sudo ./FireMotD -T Gray

Then do the:

sudo ./FireMotD -S

I rebooted afterward, but that may not be necessary.

Hope that helps!


Garret, @Falcon1980

thanks for your proposal, it worked fine for me. For safety reasons, I made also a reboot.
Now OH 2.4.0-1 stable release started without any problems!

I do not press the solved-button, cause @GeorgJ is the owner of this thread.

1 Like

Thanks Garret,
your proposal worked for installation - also after a reboot.
I will close the thread.
Best regards from Germany

1 Like

You can’t close a thread :wink: but only mark the posting with the solution (would be Falcon1980’s),
please also change the Thread title (from the very first Posting) to [solved] …

1 Like

@Falcon1980 Thanks! It worked for me also!

1 Like

I had to install FireMotD in between.

cd /opt/FireMotD
sudo ./FireMotD -I -v
sudo ./FireMotD -TF /opt/FireMotD/themes/FireMotD-theme-Gray.json
sudo ./FireMotD -T Gray