[SOLVED] Waiting for openHAB to become ready ... failed

Good evening,

I am a very beginner who wants to install openhabian v1.5 (openHAB version 2.4.0) on a raspberry pi 4B. The first big issue was to install java which I was able to manage by following this solution ending up with the following java-version:

openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

So far so good. But every try (three to four) to reboot the system ended up with the following mistake (log-file):

2019-10-29_21:07:46_CET [openHABian] Setting up Samba network shares... OK
2019-10-29_21:07:48_CET [openHABian] Installing the openHAB Log Viewer (frontail)... OK
2019-10-29_21:08:11_CET [openHABian] Adding an openHAB dashboard tile for 'frontail'... Replacing... OK
2019-10-29_21:08:11_CET [openHABian] Execution of 'openhabian-setup.sh unattended' completed.
2019-10-29_21:08:11_CET [openHABian] Waiting for openHAB to become ready...1..2..3..4..5..6..7..8..9..10..11..12..13..14..15..16..17..18..19..20..failed.

As a new user I am not allowed to upload a file, so I will post the whole file if necessary.

I am working on it for hours right now and I am very frustrated. It would be great, if you could help me with it.

Thank a lot in advance!



it’s me again. I solved the problem by upgrading openHAB testing:

sudo openhabian-config

point “40 openHAB related” => openHAB testing

After the installation I reboot the raspberry and everything went fine :slight_smile:

I am sorry for opening an own thread for it.

Thanks and see you soon

So you installed version 2.5 Milestone 4. You might want to go to the stable version once 2.5 is released toward the end of this year.

Thanks, I will keep it in mind.