[SOLVED] Weather binding with OH2 - does it work?

the binding is installed, the yahoo parameters configured, but the logs dont show any connectivity to yahoo, and none of my values are updated.







Number Wind_Speed_Mph “Windspeed [%.2f mph]” (gLogicalSwitches) {weather=“locationId=home, type=wind, property=speed, unit=mph”}

Number Temperature “Temperature [%.2f °C]” (gLogicalSwitches) {weather=“locationId=home, type=temperature, property=current”}

Number Humidity “Humidity [%d %%]” (gLogicalSwitches) {weather=“locationId=home, type=atmosphere, property=humidity”}

2018-10-15 17:50:22.639 [DEBUG] [eather.internal.common.WeatherConfig] - Parsing of weather configuration settings completed.
2018-10-15 17:50:22.639 [INFO ] [eather.internal.common.WeatherConfig] - LocationConfig[providerName=YAHOO,language=en,updateInterval=10,latitude=,longitude=,woeid=26473518,locationId=locationId1,name=home]
2018-10-15 17:50:22.639 [INFO ] [eather.internal.common.WeatherConfig] - LocationConfig[providerName=YAHOO,language=en,updateInterval=10,latitude=,longitude=,woeid=26473518,locationId=,name=home]
2018-10-15 17:50:22.649 [DEBUG] [al.bus.WeatherGenericBindingProvider] - Adding item Wind_Speed_Mph with WeatherBindingConfig[locationId=home,type=wind,property=speed,roundingMode=HALF_UP,scale=2,unit=MPH]
2018-10-15 17:50:22.654 [DEBUG] [al.bus.WeatherGenericBindingProvider] - Adding item Temperature with WeatherBindingConfig[locationId=home,type=temperature,property=current,roundingMode=HALF_UP,scale=2]
2018-10-15 17:50:22.654 [DEBUG] [al.bus.WeatherGenericBindingProvider] - Adding item Humidity with WeatherBindingConfig[locationId=home,type=atmosphere,property=humidity,roundingMode=HALF_UP,scale=2]
2018-10-15 17:50:22.664 [DEBUG] [.weather.internal.gfx.WeatherServlet] - Starting up weather servlet at /weather
2018-10-15 17:50:22.669 [DEBUG] [org.openhab.binding.weather ] - ServiceEvent REGISTERED - {javax.servlet.ServletContext}={osgi.web.version=1.12.0, osgi.web.contextpath=/, service.id=384, osgi.web.symbolicname=org.openhab.binding.weather, service.bundleid=226, service.scope=singleton, osgi.web.contextname=custom} - org.openhab.binding.weather
2018-10-15 17:50:22.679 [DEBUG] [org.openhab.binding.weather ] - BundleEvent STARTED - org.openhab.binding.weather

this morning i changed from Yahoo to ForcastIO, however still no updates, and looking at the logs no request is being made via the API.

I also notice there is no ‘thing’ created, is this correct?

Am I missing part of the installation?

It’s like it’s all installed but the API call is not being triggered.

Still no errors in the log after changing provider…

The data i’m trying to get is wind-speed, if the OH1 Weather binding isn’t compatible with OH2, do i have an alternative please?


You locationId is locationId1
So you need to use that in the items’ bindings or change the locationId to home



Correct, it’s an openHAB 1.x binding to it needs to be manually configured with a cfg file and binding definitions in the items. There will be no Things and Channels

No, but you did not read the documantation properly and didn’t use the locationId parameter as per the examples

You can try:

I use both

Just to reassure, I use 1.x binding with OH2 for Yahoo weather.
Very occasionally, Yahoo does not play nice but it is working today.

I now see my error :slight_smile: thanks very much for pointing me in the right direction

Please mark the thread as solved. Thanks