[SOLVED] Weather Underground - Uninitialized

Ok, I thought I knew a little about OpenHab, but I find out every day how little I really know.

I have had WeatherUnderground working for months, but I have done something that OpenHab does not like, and it quit, 4 days ago. I even tried uninstalling it and re-installing it. Both before and after, I come up with:

### Weather


Weather forecast from The Weather Company


## Channels

PWS Current Observations *unfold_less*

Current observations from Personal Weather Station

### Current Temperature



I have no idea what it is talking about with the error message that says; Uninitialized - Handler_Configuration_Pending.

If you need any more info, please request it, as I do not know how much info will be needed.

BTW, my weather.cfg shows the following:







I have started looking at using the darksky weather binding. That may be an option for you.

As @sihui points out, WeatherUnderground announced End of Service quite a while ago (with one exception that I mention below).

This means the thing configuration is not complete.

However, I’m confused about what you’re doing.

This is not WeatherUnderground. It’s the binding for pulling weather forecast and PWS data from The Weather Company. In order to use this binding, you need to upload personal weather station data to WeatherUnderground.

Yes, I realize this is a bit confusing. IBM owns both WeatherUnderground and The Weather Company. A few months back, IBM eliminated free access to the WeatherUnderground API. But, for people who uploaded their Personal Weather Station (PWS) data to WeatherUnderground, IBM gave them free access to The Weather Company API.

This is not the way to configure The Weather Company binding. The Weather Company binding uses things that must be configured using Paper UI or with a .things file.

1 Like

Ok, I stand corrected, as I use The Weather Company’s binding and API. Sorry, I erred in the wording. I was aware that the WeatherUnderground was discontinued, and I moved over to the Weather Company. It was worki9jng until last week, and I may have messed it up while I was trying some other things.

Anyway, how do I configure the Weather Company thing? I thought I had it configured under my main thing. I guess I will attempt to do that.


It’s explained here.


1 Like

Ok, great. Thanks. I created a weather.things and weather.items files and it started working, again. However, I wonder why it ever worked in the first place. Anyway, thanks for everything.