[solved] What's the proper process of setting up IDE right now?

Tags: #<Tag:0x00007efebf9c6c50> #<Tag:0x00007efebf9c6b88> #<Tag:0x00007efebf9c6ac0>

I have been contributing small patches for ESH every now and then for some time, and sometimes when I update from upstream something somewhere breaks. This is the process I usually use:

  1. Fetch upstream and rebase my master
  2. Run mvn clean install is Eclipse Smarthome folder
  3. If it failed:
    1. Try git reset --hard
    2. Try git clean -xdf
    3. Try nuking ~/.p2 (seems like an overkill, but this actually helped a couple of times)
  4. At this point Maven can build the whole ESH
  5. Open Eclipse and hope I don’t get any errors
  6. If there are errors:
    1. Try to import missing projects, if any.
    2. Try nuking Eclipse and installing it again using Eclipse Installer.

Usually these steps are just enough to get a working development environment, but for some reason right now it doesn’t work and I have tried every single method listed here. Maven builds the project just fine, but this is how it looks right after project are imported and built after Eclipse installation:

Here is how I use Eclipse Installer:

I understand openHAB and ESH are huge projects with very complex build process and I wouldn’t be asking but I’m all out of ideas. What am I doing wrong here?

After a couple more tries (and deleting Eclipse Installer data) I’ve decided to open an issue.

1 Like

I’ve had this problem. I don’t have a solution, really, but I’ve found that closing all the projects and then opening only the one I’m currently interested in working on allows me to work without the 10000 errors.

Found a solution that worked for me: