[SOLVED] When I use a MAP file, my group menu will not open

I have a problem using a MAP file that is most outspoken when i use my phone app
I am measuring the current used by my washingmachine.
then I use a rule to assign a (numerical) state to indicate the phase it is in.

My items look like this

Number Washingmachine_Power "Wasmachinepower [%d]" <washingmachine> (Machines) {mqtt="<[mosquitto:home/wasmachine:state:default]"}
Number Washingmachine_Status "Washingmachine Status [%d]" <washingmachine> (Machines)

My rule looks like this

val Number MODE_OFF = 0
val Number MODE_STANDBY = 1
val Number MODE_ACTIVE = 2
val Number MODE_FINISHED = 3

rule "Washingmachine Consumption State Machine"
    Item Washingmachine_Power changed
    if (Washingmachine_Power.state <5) Washingmachine_status.postUpdate(0)
    else if (Washingmachine_Power.state<10) Washingmachine_Status.postUpdate(1)
    else if (Washingmachine_Power.state<15) Washingmachine_Status.postUpdate(2)
   else if (Washingmachine_Power.state>15) Washingmachine_Status.postUpdate(3)

That seems to work fine:
in my basic UI it looks like this

and in my phone app like this

However, I want some textual feedback on the statusso I added a MAP to the second line in the items file like this:

Number Washingmachine_Status "Washingmachine State [MAP(wasmachine.map):%d]" <washingmachine> (Machines)

My MAP file looks like this:


Now something odd happens.
My basic UI now looks like this, what i expect, but I have to give a refresh before it appears.

However, my phoneapp just refuses to open the group that the washingmachine is in. The moment I remove the MAP command, it opens immediately again, but when I add the map, the group won’ t open.

I am using maps in other parts of my item file and that never caused a problem.

Anybody any idea?

I think I alrady solved it myself, changed :%d into :%s
odd, I thought I had tried that before already without result, but now it did well