[SOLVED] Wol can't wake up my win 10 pc after 10-15 minutes

Platform information:
o Hardware: Amlogic S905X3 Quad Core 4x ARM-A55 @ 1.9GHz (64bit) GPU Mali-G31 MP2 12nm / 4Gb ddr3 ram / 32gb eMMC
o OS: ARMBIAN linux Ubuntu 19.10 (Eoan Ermine) arm64
o Java Runtime Environment: 8 version
o openHAB version: 2.5.1
Wol binding can’t wake up my pc after shut down 10-15 minutes later, but my router with wol functiun button always wake up my pc.

I click shut down button in win10, my pc turn off. After I say Alexa, turn on my pc, my pc turning on, but after 10-15 minutes can’t wake up my pc.
I have a router with wake on lan function button, this button always wake up my pc, but openhab wol binding can’t.


Switch networkPC "Computer" Switchable (network, gOGBuero) { wol="" }

I logged lan wol packets with wireshark: (Logged with “destination pc” with wireshark, pussh router wol function button and activate openhab wol binding)

  • Openhab magic package type: IPv4 (0x0800) / Destination: AsusTek_4e:o7:98 (my pc mac address)
  • Router magic package type: Wake On Lan (0x0042) / Destination: Broadcast (ff:ff:ff:ff:ff:ff)


  • setup static ip on router
  • setup static ip on “destination pc”
    • NIC config: Enabel wol, magic package
      Disable energy saving, deep sleep
    • BIOS config: Enable wol
  • add static ip to the linux server ARP table
arp -s IP MACaddress

(After shut down destination pc the linux server arp cache cleared 10-15 mins later.)

How are we supposed to know ? It’s like asking “I’ve got 3 cars that drive. Why does #4 not ?”.
Search the forum. This yields e.g. this: WOL - Binding Problem with Samsung Smart TV

1 Like

Do you have a network packet capture showing what the router sends vs what openHAB sends? That would be an obvious troubleshooting step. What have you tried that did not work? We provide HELP, not solutions.

We would need the normal information on your OH system and configuration too. We are not volunteer mind readers here.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

I used this:
sudo setcap ‘cap_net_raw,cap_net_admin=+eip cap_net_bind_service=+ep’ $(/usr/bin/java)
After Openhab restart, can’t start (status:127) error.

This command help me to solve:
sudo setcap -r $(realpath /usr/bin/java)

So I don’t know this helped me?

Thank you, I edited my post, I am new here.

I captured the lan wol package packagea with wireshark:

This is enough information to the solution?