[SOLVED] Xiaomi Mi Smart Home 2nd Gateway is not recognized

Because of range issued I have added a sencond Gateway to my installation.
The gateway is configured via the Mi app. In PaperUI the 2nd gateway is not recognized.
That leads to the question: Are multiple gateway supported by the binding ? If yes how is it configured ?


More than one gateway is supported. I have 2 xiaomi gateways running without any problems.
But you will need to follow the same steps as you have done for the first.
See https://www.openhab.org/addons/bindings/mihome/

The developer key is needed for each gateway and is also different per gateway.

Thank you. I forgot how I configured the first gateway a long time ago. Unfortunately the instructions are outdated and the ios app has now different menu items. I was not able to get into developper mode anymore. Does anybody have a suggestion ?

OK I figured it out.In the ios app you still use the menu item about (über) and then you have to tap 5 times in the bottom area of the screen. Then you get three chinese lines.
The first line is just some information.
Use the second line that is a menu.
Then you can proceed as described in the instructions.

To extend the range, is it enough to configure the second gateway via the Mi App or is at actual nessecary to add it via paper UI?

Yes, if you want the same functionality you will need to add the second gateway in Openhab the same as you have done with the first one.

A second gateway creates a second network, and will not work as a repeater of the first one. Devices needs to be connected to one of the gateway’s.


Thank you for your reply. I thought any xiaomi device with main power will work as a repeater in it´s zigbee mesh network. This would be enough for me. Just range extention. Is this possible at all?

Otherwise I´ll have to set up the second gateway and delete half of my sensors and reconnect them to the second gateway, redifining all the channels etc. …


A second gateway will not function as a repeater ( i had bought my second with the same intention… ). It only creates a second xiaomi zigbee network.
For repeating you can better buy a socket or an other mains powered device.


Thank you. Can you recommend any devices of any brand that work as a xiaomi repeater for you? (As far as I know the xiaomi sockets don´t exist with euro plug)


I only use de xiaomi stuf for there ‘cheap’ sensors en switches. But basically every mains powers zigbee device that is supported by the gateway should work. Check the Xiaomi App for supported devices and you should find something.

Okay I have another issue now. I realised that in thing settings you can choose the bridge for that thing. So I changed the bridge for some sensors to “bridge 2”, the second gateway in the upper floor. I have multiple problems ow:

  1. The things (upper floor) that I changed to bridge2 are all shown offline in paper UI
  2. The things from upper floor that are in reach of the first gateway work anyways
  3. To solve the problem and have them shown correctly in openhab and the mi App I deleted two things from the upper floor, in openhab and in the mi app. A window sensor and a smoke sensor. I did the pairing again and chose the second gateway but it doesn´t work. I selected the first gateway again. It doesn´t work. I tried again with the other gateway beeing power off. Doesn´t work. Also I tried to add the thing manually. I can´t get the sensor I deleted back to life. It drives me nuts.
  4. I tried to connect a brand new sensor. This also does not work any more.
  5. I can controll both gateways through openhab, e.g. turning on the light.

What is going on?

As far is I know if you want to have devices from bridge 1 to brigde 2 you will need te delete them in Paper-ui, delete them from Bridge 1, and add them to brigde 2. The will pop-up in paper-ui.
That is what I have done.

Most likely the thing ID from a device is not the same when connected to another bridge. So the thing in paper-ui will stay offline.

But if you find a way to just change devices between bridge 1 and 2 without connect/reconnect let me know.