[SOLVED] Z-wave binding can not select the right serial port for z-wave stick (aeotec) under paper UI

I am trying to set up my aeotec z-wave usb stick under paper ui, but I can not chose the right serial port in the drop down menu. Under /dev/ I find the right port (ttyACM0) but in the dropdown menu there is only an other serial adapter (ttyNET0) from my smartmeter binding (ir usb device).

sudo dmesg || grep tty gets me a device: [   26.243496] cdc_acm 3-2:1.0: ttyACM0: USB ACM device

I am using openhab 2.4 on Ubuntu 18.04. on a virtual machine (Synology VMM). Since today I have no more problems with usb devices. I have reset the permissions with the openhabian-config tool, so permissions should not be the issue.
I there a possibility to setup the controller via thing file to set the port manually?

Thank you for your help!


That would be an operating system issue separate from OpenHAB.
Perhaps your USB stick, port, or cable are bad.

At least for my VM (VirtualBox) I have to map the usb device from the host system to the guest system.

1 Like

Good catch. I missed that important detail.

Is done, mapping seems to run because I get the seria port tyyACM0.
Mapping is not the problem. But I can not chose this port in paper ui.

Not likely the issue but the preferred way of managing zwave is through the HABmin interface.

I solved by installing openhab 2.5M3. After the update the serial port was listed.
But i don’t know why the port was not listed under version 2.4.
Thanks for your help!