[SOLVED] Z-Wave Fibaro Motion Sensor and Fibaro Flood Sensor After connecting have NaN values (all), on PaperUI control panel is empty

please, help me.

I tested ZWave device Fibaro Motion Sensor and Fibaro Flood Sensor with Aeotec Z-Stick Gen5 (ZW090-A), devices are successfully connected (with status ONLINE) but on the control panel, there are no any connected devices with properties. And even I will add any items to the device properties is still have NaN values.

I test on 3 different Aeotec Z-Stick Gen5 with 2 Motion sensors and 1 Flood sensor, the behavior is the same.

@sihui or @chris Please help untangle this.

My guess is that the devices are simply not fully initialised and just need to be woken up. However it’s a little hard to comment as there is very little information provided here.

So, my suggestion is to wake up the devices (read the manual to find out how to do that - each device does it differently) and if that doesn’t work, please provide information on what is shown in the UI (eg the device properties) or a debug log.

1 Like

Hi Chris,

thanks for your quick reply.
I made a lot of ‘Wake Up’ tries but did not help.
I see in the Z-Wave debugs logs that properties are changing (for example, when luminance is changing on device), but nothing is changed on the control panel.

You can download logs and screenshots from next link https://drive.google.com/file/d/1XtycDvU61_07hu6a5fHxNw2v0ZAQjlh9/view?usp=sharing.

Hope this help.

Thanks a lot.


I had a different motion sensor last week that showed luminance changes even though is was not fully configured and would not show motion. I found that, for some devices, I exclude from the network (deleting the Thing too), Factory reset the device, and then include.

Yes, did the same with my devices, hard reset of Aeotec Z-Stick Gen5 , hard reset of Fibaro Motion Sensor and Fibaro Flood Sensor but still getting the same.

You are including through OH discovery and not a button on the stick, correct?

  1. Go to the Inbox and click +
  2. Select Z-Wave binding
  3. Search device is starting
  4. Then click three times on B-button of the Motion sensor
  5. Device has occurred
  6. Click to add the Thing
  7. The device successfully added and ONLINE.
1 Like

Don’t you need to do this part next?

1 Like

Thanks a lot. It helps. I changed all Association Groups to controller and it working.

You should note that this will likely cause problems as the binding will now likely receive multiple (duplicated) messages. You should only need to set the lifeline, and if you are using 2.5 this should be done automatically.

Thanks a lot @chris

1 Like

Does that mean a check and warning can be removed from the database?

I’ve no idea as I’ve not looked at the database definition - what check are you suggesting to remove?

An example from item 74 (chosen at random)

This is a question about adding a checkbox to one of the association groups. I’ve not looked at hte device so I don’t know if it should be added. This is basically displayed on the premise that for most devices there should be at least one association linked to the controller so that the controller knows what is happening.

What we are talking about here is if the user manually adds the controller to ALL associations, then there will be duplication.

Again - here I thought your question was about removing something on a specific device. I’m not sure how to answer your question if it is of a more general nature?

More generally, is that database check still needed if the binding automatically links a group to controller?
That was my, admittedly general, question.