[SOLVED] Z-Wave Intermatic Split Duplex Receptable is not recognized

You could try downloading the JAR and putting it into the addons folder. You just need to be careful to remove the old binding, and also install the serial bundle if you don’t have other bindings with the serial bundle loaded.

Ok, I am new build and I have device recognized as “15 Amp Split-Duplex Receptacle”, however for some reason openhab2 thinks that it’s Dimmer and it has Brightness channel: “The brightness channel allows to control the brightness of a light. It is also possible to switch the light on and off.”

When I link to item at use it - nothing happens :frowning:

Looks like information in DB is incorrect :frowning:
It should something like this: http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/304

same here my dimmer thinks its a Split-Duplex as well.

And this IS my split-duplex plug

Ugh… honestly, I’d love to have an option to manually override everything, instead of relying on DB that is updated not very often :frowning:
It’s been a week+ and I couldn’t get simple receptacle working with OpenHab2, I tried HomeAssitant last weekend and at least it recognized it without problem…

yeah I hear you. like an upload button that would let us pick what it is.

maybe ill spin up a HomeAssitant VM again and check it out.

If the database has the wrong information in it, then it would be good if someone can work out what is wrong and update it - it will get fixed a lot quicker that way ;).

Ill work on that today and see what I can do.

1 Like

@chris, absolutely! Do you have docs on how to experiment with DB locally? I tried to do the following:

  1. Uninstalled Z-wave bindings from UI
  2. Made sure that I have serial handler
  3. Downloaded z-wave binding http://www.cd-jackson.com/downloads/openhab2/org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar
  4. unpack it: ‘jar xf org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar’
  5. Edited ESH-INF/thing/intermatic_ca3500_0_0.xml
  6. pack everything back into jar: ‘jar cf org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar ESH-INF META-INF org OSGI-INF’
  7. Copied it to /usr/share/openhab2/addons
  8. Restarted the openhab2 service

And nothing happened - openhab2 didn’t picked up this bundle, and bundle:list | grep zwave shows nothing :frowning:

Could someone provide instructions how to build zwave from source code, from dev branch for example and install it?

Ok, I got this device working as I want. I used master branch, but any build would work, I imagine. This also could be used to manually add/modify zwave database locally
0) Uninstall existing bindings from UI

  1. git clone https://github.com/openhab/org.openhab.binding.zwave.git
  2. apply changes: https://pastebin.com/TjxKjpmN
  3. If not installed, install mvn, on OSX - ‘brew install mvn’
  4. mvn package
  5. scp target/org.openhab.binding.zwave-2.2.0-SNAPSHOT.jar openhabian@:/usr/share/openhab2/addons
  6. restart openhab2 service

Everything works, CA3500 recognized as binary switch and works correctly

Trying this now. building, works. sees the 3500 now

might need some time or a exclude/include to update the name.

It would be great if you could make the changes to the online database, so other users with this device can also benefit from your findings.

we just got them working. I’m sure the OP is on it and will get this info in ASAP.

1 Like

I update DB, requested review, MULTILEVEL channel needs to be deleted, as @chris said, I marked it as “DELETE ME”

1 Like

Thanks, but the database is now inconsistent - you have a binary switch, with a multilevel type so something is not correct. As requested via email, please can you post the XML file for this device so I can check what the configuration should be.

Thanks for the XML @ikir . I’ve now updated the database to reflect your device and added the switch channel.

My guess is that whoever added this device originally probably named it incorrectly so we’ve possibly ‘hijacked’ another device. Anyway, never mind - I think this now correctly reflects the CA3500 and we’ll worry about a potential problem with another device later :wink: .

Sooo… just tried to add my CA6000 dimmer light switch along with my CA3500 Plugs… and the Node 10 I added CA6000 came in as

Z-Wave Node 10: CA3500 15 Amp Split-Duplex Receptacle ONLINE
CA3500 15 Amp Split-Duplex Receptacle

node10.xml (4.0 KB)

edit your post and use code fences to post the xml contents:

content goes here

or even better drag and drop the xml file in your post.

Fixed :slight_smile: Thanks

1 Like