[SOLVED] Z-Wave Intermatic Split Duplex Receptable is not recognized

Hi, I am very new to openhab, so apologies if I am asking wrong question.
I’ve had Intermatic InTouch CA3500 Z-wave Split Duplex Receptacles for few years and I’ve been using it with SmartThings hub, few days ago I decided to give openhab2 and raspberry Pi 3 a shot.
I have Z-stick form Aeon Labs, I tried to add Receptacle to “Things”, but wasn’t recognized, I see this in logs:

2017-07-13 20:08:03.177 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:controller:node3’ to inbox.
2017-07-13 20:08:31.633 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing ‘zwave:device:controller:node3’ takes more than 5000ms.
2017-07-13 20:11:31.373 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 3: Unknown command class 0x91
2017-07-13 20:11:31.786 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 3: Unknown command class 0x91
2017-07-13 20:11:33.009 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery could not resolve to a thingType! 0005:4341:3500::1.101

I can’t upload node3.xml attachment…, so here pastbin link: https://pastebin.com/z89qzi37

I am not sure what the process to add new device support, can I do it myself somehow?

It seems that the device is already included in the Z-Wave database:

So, there could be 2 reasons why the node is not properly recognized:
i) either the database entry needs an update
ii) or the device initialization didn’t complete properly

Try to remove the node3 thing and to re-add it from PaperUI. Maybe this will help.
Which release of openHAB are you running? (you can see the release # on the root (/start/index) page of your OH system (http://<OH2_IP>:8080>)

You have a different version than is in the database, so we’ll need to update the IDs with those from your device. The link from @Dim is correct, but the IDs need to add 4341:3500 for your device.

1 Like

@chris, again, I am not familiar with the process is that something I can do or I need to wait? Any additional information you need from me?

There’s nothing to do - @sihui has kindly added this to the database already so it will be in the next version (probably I will do an update tomorrow).

That’s awesome! Thank you @chris and @sihui. How do I get an update? Just re-install Z-wave bindings?
For future, is there docs that I can read about DB and how to add things there myself?

I am trying to move my install from OpenHAB to OpenHab2 and facing the exact same problem. Same hardware as well.

I managed to get the CA3500 working in OpenHAB with the great help of Chris a long time ago. I was pretty comfortable working with OpenHAB, files and rules but I am a complete newbie when it comes to OpenHab2.

Looking forward instructions on how to fix the local database.


So, to be clear, your device has the same IDs as mentioned above?

You need to be using the latest snapshot of the binding and it will have the updates.


Yes, I would think the ID are the same. I don’t know where the LOGS are for now (Windows 10 machine for testing before final deployment on RPI3) but this is what I have in PaperUI:

Node 13 (0005:4341:3500:1.101)
Unknown Device


Ok, great, so you should just need to update the binding then as this was added yesterday…


I checked BUNDLE:LIST in the Karaf console I saw ZWAVE binding and version. I believe it was 2.0.0 but I forgot to note. I stopped the bundle then uninstalled it also from the console. From PaperUI I also removed ZWAVE then added it back. It discovered several 4341:3500 devices but they are still Unknown Devices.

BUNDLE:LIST shows ZWAVE at version 2.1.0. It that the latest version? If now how do I upgrade the bundle to the latest snapshot (Windows 10 machine)?


Are you using snapshot versions, or the release version? If you are using the release version, then it will always install the same binding (ie 2.1 release version). You need to be using the snapshot runtime for this to work…

Oh! I am running the distribution version downloaded here:

I guess I will have to delete it and install the snapshot version. Where can I download the snapshot versions?

It depends on your installation environment etc, but you should find the download links in the docs.

I managed to download the latest snapshot (I was not expecting the download button image was actually clickable!).

Zwave binding looks updated:
185 | Active | 80 | | ZWave Binding

However my CA3500 devices are currently sitting in the Inbox as Unknown:
Unknown Device
You are about to add a new thing Z-Wave Node 23 (0005:4341:3500:1.101) (zwave:device:f92698e2:node23) from the inbox.

Any idea what is wrong and what I can check next?

Looks like 2 other devices on my zwave network are not known to OpenHab2:

  • Z-Wave Node 19: LSM-15 Wall Mounted Switch (zwave:device:f92698e2:node19) **
  • Z-Wave Node 20: VRF01 Scene Capable Quiet Fan Speed Control (zwave:device:f92698e2:node20)**

Both were working on OpenHab.

Feeling so close ! :wink:


Yes, but it’s still old - ie it’s not the latest.

I’m not sure how you are installing your system, but it might take another day (maybe!) to flow through the system. Or, it may be that other things are stopping it being integrated into the build - I note that there was a test failure on the RFXCOM binding last night, so maybe this is an issue.

Both are in the database, but you haven’t said what your device IDs are?

Hm… I updated openhab2 and it points to latest version: https://openhab.jfrog.io/openhab/openhab-linuxpkg/pool/main/2.2.0~20170715040819/ but Zwave binding version is the same as @Eric_Belanger’s…

I’m not sure - the build is hierarchical so presumably something further up has not rebuilt. I’ve just kicked off another build to see if the RFXCOM errors are solved in case this is the problem.

1 Like

Looks like RFXCOM test failed again… @chris is there any way to update just Zwave bindings without updating openhab2 build? Like download jar and put somewhere where it can be picked up by openhab2?