[SOLVED] Z Wave nano switch in France shows up unknown

any news? did you have time to build a new binding?

Not yet, sorry - I had to go to work today :wink:

tell me about it! work always seems to get in the way! What timezone are you in?

UK (most of the time - EU some of the time :wink: )…

so, sensible then, I’m in Geneva. Do you think we could start a bit of an initiative to include the Somfy Tahoma API? I’d really like to integrate my somfy stuff. I"m happy to do some coding… would just need pointing in the right direction.

Personally, I know nothing about this, but a quick search on the forum does bring up at least one thread that looks like someone is working on something so you might want to take a look at that…

thanks. I’ve posted on there too.

Hi Chris,

how to I pick up the new database so I can get the nano switch up and



You just need to change to the latest snapshot version of the binding.

I’m a virgin… how do I go about that? it’s my first time.

it’s ok, I found something on the forum. I’ll give it a go.

It appeared to work, even though the version number of the binding still
shows 2.1.0. Not sure if that’s meant to be the case. the dropdowns for the
switch mode for the dimmer are now correct, and the switch comes up. All I
have to do now is work out how to configure the switch so that when I
Activate it, it deactivates itself, I need an impulse, as it’s replacing
the impulse switch for the garage door.


I was wondering furryboffin if you got your nano switch to work? Is it a nano switch or dimmer?
Reason I ask:
I just bought a aeotec nano dimmer(coming from shop in Netherlands, living in Belgium) and a zwave.me UZB1 controller … trying to step into the wonderful world of domotics :yum:
However after hours of fiddling and trying different softwares (home assistant, domoticz, openhab2, z-way server) and different of hosting hardware (linux ubuntu running on intel atom, raspberry pi, windows 7…) I’m out of ideas and decided I needed to ask somebody for help
Having checked out different softwares I’m currently more in favour on wanting to use openhab as it has good tutorials and seems to have a large community backing it.

I’ve tried hard resets, factory resetting the nano dimmer every time before I include it, tried adding it secure or just adding it the normal way… but I don’t know what is going wrong, my guess is that the nano dimmer is not supported (yet)?

Here is the z-wave logging of an inclusion


my zwave binding has version :
180 | Active | 80 | | ZWave Binding

I think the inclusion is succesful ( because the led of the nano dimmer stops blinking after adding it, if i don’t put the controller in inclusion it keeps blinking longer until it shows red LED)
But again… I’m very new to this subject … I just bought these two toys before deciding on how to reorganize my living room lights and switches

Any suggestion, help is very much appreciated, thanks!:wink:

Kind regards


Dear @chris ,

I have same problem too.
I’m using OpenHAB 2.1 and installing binding-zwave - 2.1.0.
But the Z-Wave Device - Nano Switch (ZW139-C, EU) is “Unknown Device”, not in database.
Could you please advise me how to solve this problem ?

Thanks so much for your support !


What device type/id does your device report? Does it just show unknown device, or are there some numbers? If you look at the properties, does it show the device type/id?

Thanks to Chris adding the device ID to the DB, I got it all working fine. Drop me a message if you still have problems

Dear @chris,

This is my device report

Thank you so much !


Thanks. It looks like this is already in the database and you should use the latest snapshot version of the binding and it should work ok I think…

Thank you so much @chris.
Do you have link download jar file of latest snapshot version. I downloaded org.openhab.binding.zwave-2.2.0-SNAPSHOT.jar file but it doesn’t work in my OpenHAB ( not active )

You need to make it active :wink:

Uninstall the current binding, drop this version into the addons folder then start it in Karaf. You may also need to install the serial driver (depending on what other bindings are running. This can be done with -:

feature:install openhab-transport-serial