[SOLVED] Z-Wave- no data from POP rain meter after discovering

I would connect t " NEO Coolcam NAS - SC01ZE", the things was fast discovered. But I can’t configure the thing correctly, so I had delete and add it sometimes.
Now I got a problem:
I can’t delete this thing and also not another thing, not in the habmin and also not in the new switch in the paper-ui. The thing should be deletet, when I call the function repeately there is a message “thing not available”, But when I start the discovery, the 2 things are very fast in the inbox. I try it with a new reboot of my Raspi, it’s the same problem. Another curiosity: the ID’s of the things are not constant, there is a gap of 6 ID’s.
I’d by a new Thing (POPP POPE700168 Z-Rain Regensensor Regenmesser). It was fully discovered after 6 hours, but there are no data after two days available.? My Z-Wave-Controller is “Z-Wave USB Stick (ZMEEUZB1)”. I’m using ObenHab 2.4.
Can anybody help?

Can you show the logs of the actions you describe above, please?

Hello Vincent,
thanks for the fast reply.

Yesterday I’d test the delete of the 2 items again after 7 days- amazingly one thing was been deleted (it could occured after the last restart) and the other thing I’d erase without problems on yesterday.
So this is solved :slight_smile:

The second problem, the rain meter:
I’d try to include in the network on 2019-08-23, and waiting in the hope, anything goes well.
It does’nt, and in the moment I’m working far from home (250 km) and the device is also far from home (and the system) as I. Amazingly the device is always Online.?
I don’t know, it’s a problem with the software or the device is defect- so maybe I must return it to Amazon.

I’ll send you 3 files:

With greetings

I’m not 100% sure , but it might be related to a missing channel definition basic_number in the binding. I’ll update that later.

It would help in future to use debug level logging so if this isn’t fixed by the change I mention here, then please provide debug logs and I’ll take another look.

Hello Chris,
In the moment I can’t change anything on my hardware, and the device is not connected.
If necessary, I can try something on the next Saturday (2019-09-07). If you need more Info, please let me know it. :slight_smile:
PS: I’d update the subject from ‘can’t delete things’ to ‘Z-Wave-no data from POP rain meter after discovering’

I’m not talking about changing anything on the hardware - these are just software changes.

Mine is working fine in 2.5m2.

1 Like

I think the missing channel is a command that can be sent when rain starts. I was wondering if the lack of this channel definition was preventing the thing initialising at all, but I guess not if it works for you.

Yeah its a heavy rain notification. I haven’t tried it yet. But the other parts work as far as I can tell. I plot graphs in influx and so far it’s been working.

Regards, S

After 2 days online there was not any data available from the device:

The manual of the device you will find here: www.popp.eu/700168en
When it runs on OpenHab 2.5.M1, I’ll try again on Saturday on OpenHab 2.4 or, if it fails, the next week on a test system and OpenHab 2.5.M1.

Why not 2.5M2 ?

after playing around some times on my test system now it’s runing as expected on OpenHAB 2.4.
Why it doesn’t run on my life system in the past I don’t know. There was two days no data at all.
But I’ll see whether it run on the other system in the next days.
Many thanks for the help!
:slight_smile: Jens

1 Like

I don’t manage to get that device working with 2.5.0.
Discovery worked, it seems to be online but I not data updates even though I simulated heavy rain (by simply hosing it down for a good while). I don’t even get the battery charge, like in your screenshot above.
I uploaded the log files to the logfile viewer but couldn’t see any trace of that device.
I then tested in Simplicity studio and I did see reports from the device (after hosing it down for a little while). So I am pretty confident that the device itself works put the reports somehow get lost. It also looks like I’m not the only one experiencing that issue.
Does anybody have an idea how to get that device to work with openhab?

It’s a battery device, so wake it up multiple times:


Check if an xml file has been created in your userdata zwave folder.

So I finally got it working. Here’s my receipe for those who struggle with htis device.
First of all arm yourself with a fresh set of batteries and a toothpick (or similar).
The following steps got me there:

  • Include the device into the network by putting openhab into inclusion mode (I did that in PaperUI) and pressing the z-wave button as explained in the manual with the toothpick (you may need to repeatedy press that button until successful)
  • Add the thing and switch to Habmin
  • Start openhab console: “openhab-cli console”
  • In the console window, set the log level to debug through “log:set debug org.openhab.binding.zwave”
    You will now get lots of z-wave messages in /var/log/openhab/openhab.log. It’s helpful, because you can now see if your device actually communicates with the controller. If you don’t see anything in the next few steps, you may need to get closer to the z-wave controller.
    Now you need to get on with keeping the device talking to the controller.
  • first of all push the z-wave button and check whether you see a wakeup message from that device in the log.
  • Habmin now shows the device in status “Initialising”
  • Now select the thing and set the wakeup interval to 60 (or slightly higher depending on your patience)
  • Push the z-wave button with the toothpick until the device you actually get first data (battery status) and the wakeup interval is accepted by the device.
  • Push the z-wave button a few more times. You can now also leave it alone for a while to complete initialisation on it’s own (it’ll take a bit more time depending on the wakeup-period. It looks to me like the communication does not continue even if there are still commands in the controller’s message queue)

Once the device is intialised, you can actually expect first data. In my case, there was no rain forecast for the next couple of days so I gave the device a good shower.
That finally got me some data!
Do not forget to set the wake-up period back to a reasonable value. I set it to 86400 for a daily wakeup. You may want to set a longer period in order to save batteries.
After setting the new wake-up period you need to press the z-wave button again a few times until the device accepts the parameter.
You should now be all set.
All in all I have to say that it’s quite a hassle to get this device going. I don’t know if it’s the Openhab add-in or the device.
In my case, the first lot of batteries is now empty and not a single drop of rain measured. No considerable precipitation since the device is setup in the garden. That’s Murphy’s law for IOT enthusiasts.

1 Like