[SOLVED] Z-Wave Serial Controller shows "OFFLINE - BRIDGE_OFFLINE Controller is offline"

That would explain a lot. Ok, so after stopping the openhab2 service, dropping the jar file into the $OPENHAB_HOME/addons and then rm -rf $OPENHAB_USERDATA/{cache,tmp}/*, this shows in the console:

openhab> bundle:list -s | grep wave                                                                                                                                 
 13 │ Installed │  80 │     │ org.openhab.binding.zwave

So is that snapshot 0025?

(Incidentally, the console shows 2.4.0 Release Build in the welcome message, but paper ui shows 2.5.0.M1)

But then the openhab.log file freaks out:

2019-04-08 09:08:48.584 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [13]
  Unresolved requirement: Import-Package: com.google.common.collect

	at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[?:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

But I can’t sort out where to find this com.google.common.collect package. A few posts, such as here and here seem to indicate this comes with the Guava bundle but I’m really just grasping at straws here.

I think you somehow messed up your openHAB installation during an upgrade.

Never seen any numbering like that. No, your openHAB zwave binding is snapshot #610:


But don’t worry about snapshot versions for manually installed bindings, the important part is to use a recent one and yours is from 20190407

Yep, I’m a moron. I have to plead 100% and total incompetency. I moved everything to a raspberry pi a couple of months ago, but I had a bookmark for the old openhab that was still running… which is why the zwave controller was stubbornly showing as offline… because it was plugged into the pi, but I was looking at the old laptop.

This is where I have to eat my hat with a large slice of humble pie. I really really appreciate all your help. Man I feel stupid.

1 Like

Just installed #1569. Same issues - z-wave Controller is offline. Back to#1560 and z-wave is online and devices work as they should without any further input.

I will stay with #1560 as long as there is no hint what might cause the troubles.

If I understand the comments from others above, there is no problem?

If you provide information on your problem (eg debug logs or at least some hints) then it might help us to help you otherwise it probably won’t get fixed?

I guess that problem is related to

Quite possibly. This is why it’s always good for people to explain their issue rather than simply say “I have the same problem” :slight_smile: .

Thanks - I will follow this thread and hopefully contribute anyhow. The title of the thread didn’t give me any indication that it is related to my issue.

Same issue. I am on the #1566. Just loosing the settings of the zwave controller when restarting the RPi. Every Zwave Thing is found again at every restart.

Please provide information on your issue. Just saying “same issue” doesn’t really help as we need to know what the problem is. You MAY have the same SYMPTOMS, but that doesn’t mean that the issue is related at all - of course - it might be, but it might not - we can’t tell without information on your specific issue.

That sounds like a very different issue - above the issue is related to serial ports!

Sry just noticed that I answered under the wrong thread, so I replied to the thread mentioned above.
The reason why all my things are doubled is in my opinion related to the missing port somehow.

Today I installed a RAZPBERRY board in my Pi 3, added the ZWave binding, created the ZWave serial controller thing, and added the respective items. The items show up, and have status values changing, but the thing reports “Status: OFFLINE - BRIDGE_OFFLINE Controller is offline”

EDIT: please ignore this post; I realised that for the Razberry Pi one should use the Z-WaY binding, and not the Z-WaVE binding…

Nope, a lot of users are using the RazBerry with the zwave binding.

Ok. The Z-Wave binding reports the board as Offline, but the Z-Way binding reports it as Online. So what is the reason for this?

These bindings can’t run at the same time. Remove Zway. They are both trying to use the same resources, and don’t play well together.

1 Like

Am not trying to run both at the same time. When the Z-Wave binding is installed, it reports the board as Offline. When the Z-Way binding is installed, it reports the board as Online.

Isn’t there a Zway server too? Are you running this on the Pi? IIRC, this had conflicts with the zwave binding too.

I am running the Razberry board in a Pi model 3.

If you want to use the zwave binding you need to stop and disable the zway server on the razberry board:

I tried two test cases using clean SD card images on the Pi…

A) I completely uninstalled all the Z-Way server software, and the Z-Way openHAB binding; and just used the ZWave binding; in that test case the RaZberry board is reported in openHAB as Offline.

B) I uninstalled the ZWave binding; installed the Z-Way server, and Z-Way openHAB binding; in that test case it works.