[SOLVED] Z-Wave Serial Controller shows "OFFLINE - BRIDGE_OFFLINE Controller is offline"

Ok. The Z-Wave binding reports the board as Offline, but the Z-Way binding reports it as Online. So what is the reason for this?

These bindings can’t run at the same time. Remove Zway. They are both trying to use the same resources, and don’t play well together.

1 Like

Am not trying to run both at the same time. When the Z-Wave binding is installed, it reports the board as Offline. When the Z-Way binding is installed, it reports the board as Online.

Isn’t there a Zway server too? Are you running this on the Pi? IIRC, this had conflicts with the zwave binding too.

I am running the Razberry board in a Pi model 3.

If you want to use the zwave binding you need to stop and disable the zway server on the razberry board:

I tried two test cases using clean SD card images on the Pi…

A) I completely uninstalled all the Z-Way server software, and the Z-Way openHAB binding; and just used the ZWave binding; in that test case the RaZberry board is reported in openHAB as Offline.

B) I uninstalled the ZWave binding; installed the Z-Way server, and Z-Way openHAB binding; in that test case it works.

Had the same workaround these days. Installed the zway software for making a firmware update of the razberry and geting rid of the dead nodes. You must remove the zway server in the autostart with : sudo update-rc.d z-way-server remove sudo shutdown -r now
In addition to that I had to set again the ports in openhabian- config and the port of the thing zwave controller in paper-ui. Then the controller changed to online again.

So you mean that the ZWay software must be actually present even if it is not running? Why is that?

No, there is actually no reason for having both installed on the raspberry. Both programms use same ports, so there are problems if you have the zway server running and the zwave binding.

Ok. So we are back to my original problem: with ZWay software and no ZWave it works but with ZWave and no ZWay it does not work.

Please use the search function, there are a lot of threads dealing with Razberry problems.
If you can’t find a solution open a new thread as this one has probably nothing to do with your specific problem.

I dont really see your problem. Remove all of the zway stuff and install the zwave binding. If the controller doesnt go online, just do a complete fresh openhabian install. The Razberry will work, because hundreds of people are using this zwave controller.

CFor goodness sakes guys, please look at what I have been saying…

  1. The problem is NOT a Razberry problem (because the board does work with the ZWay drivers)
  2. The problem is NOT a ZWay problem (because — see above)
  3. The problem IS a ZWave problem (because the board does NOT work with the ZWave driver)
  4. The problem IS exactly ON TOPIC for this thread (because it reports OFFLINE BRIDGE OFFLINE as in the title of this thread)

So could you please kindly stop trying to blame another piece of software, or another piece of hardware, or trying to push me off to another thread. The title of this thread describes exactly my problem, and it relates exactly to this ZWave driver.

The ZWave binding uses the standard serial drivers from ESH - it has not direct control over the serial ports etc, and there’s nothing that can be done in the ZWave binding. I think it’s reasonably unlikely to be a problem with the binding, but if it is, you need to provide supporting information.

If you are really sure that the problem is in the ZWave binding as you indicate, then it would be appreciated if you can try to debug it further as I personally don’t think it’s the case, and as the binding maintainer, there’s not much that can be done without more specific information on your problem. For example, I don’t see any debug logs here - that is always a good starting point when there is a problem (I apologise if they are provided as this is quite a long thread and I might have missed them?).

Many thanks Chris. I will post some logs next week (May 1st probably)…

I tried to install the latest snapshot from today in order to anyhow contribute, but I still have lots of troubles with assigning a port permanently to the Wave USB stick. After every restart I have to assign it manually and in several times the bridge keeps staying offline. In order to at least have a stable installation I wanted to get back to #1360 which worked good for me unfortunately it is not yet part of my cache anymore. Is there anyhow an option to re-download an older snapshot to the cache?


i experience the same problem since a few builds of the snapshot version. I came from 2.4 which doesn’t had that type of problems. I use a Razberry and no usb stick.

I tried to track down the issue a litte bit but had no real success so far.

  1. It seems the issue raises on every hot reboot of the rpi3.
  2. If I do a bundle:restart of the zwave binding the port can be opened and will be used, everything fine.
  3. I disabled oh2 server startup at boot to test if there is something concurrent running that blocks the port at startup. But it is the same here, if I run oh2 manually the port cannot be opened with the NoSerialProvider error.
  4. I tried to run a few commands like setserial but no difference at all.

If I need to guess is would say something is broken on the esh serial implementation or it has some type of race condition and needs more time on startup… but I cannot see anything at the code at least…

My solution is: Assigning the serial port another time after each reboot. For whatever reason I have two options with the same name. If I switch to the other available option / port, the USB stick initialises and switches to green. Unfortunately this doesn’t make it very reliable as the restart should be possible without a manual interaction. My feeling it is that is working better with today’s snapshot #1580 compared to the 70s. But this is only a guess.

Known issue: