[SOLVED] Zwave binding, config files, setpoint keeps going back

I am running the 2.4 version of the docker image.

I have the following configure in my things file for zwave. You can see i have tried 2 different options for connecting to the thermostat. Both will connect, and get all the channels.

Bridge zwave:serial_zstick:controller "ZWave Controller" [ port="/dev/ttyUSB0", controller_softreset="false", controller_master="true", heal_enable="true", security_networkkey="B0 8C 5C A9 1F 5F 0A C6 07 CE 9E 72 27 0B 3A 31" ] 

Thing zwave:rtc_ct100_00_000:controller:node5         "CT 100 Thermostat"                   (zwave:serial_zstick:controller) [ node_id=5, refresh_interval=120 ]
//Thing zwave:device:controller:node5         "Z-Wave Node 005: CT100 Z-Wave Thermostat"                   (zwave:serial_zstick:controller) [ node_id=5, refresh_interval=60 ]

I have an item mapped to the set cooling point

Number HVAC_CoolSetPoint "Cool Set [%.0f F]" <temperature> (gHVAC) {channel = "zwave:rtc_ct100_00_000:controller:node5:thermostat_setpoint_cooling"}

I can set the values getting pulled from the thermostat. So I can see that the current value = 74.

But what’s odd, is when i manually try to set it to 73, the log says i saw me make the change, but then goes back to 74. Like it’s not sending it to the thermostat.

2019-10-27 12:54:55.997 [vent.ItemStateChangedEvent] - HVAC_CoolSetPoint changed from 74 to 73
2019-10-27 12:55:04.473 [vent.ItemStateChangedEvent] - HVAC_CoolSetPoint changed from 73 to 74

I am trying to do this with the config files. But it seems I am missing something.

In the config for node 5, try changing the command repoll from 1500 to something greater, or disable it completely.

hmmmm. no change there. But i thought this was interesting.

2019-10-27 20:47:24.763 [ome.event.ItemCommandEvent] - Item 'HVAC_CoolSetPoint' received command 73
2019-10-27 20:47:24.769 [nt.ItemStatePredictedEvent] - HVAC_CoolSetPoint predicted to become 74

When i changed the temp through the UI it says predicted to be right back where it started.

I think i fixed it. Looks like I might have been bitten by the caching issues (again). I changed the item name (just added an “a” at the end of the name. updated the site map and no issues.