[SOLVED] Zwave binding: Fibaro fgr 223 - unknown device

Tags: #<Tag:0x00007f744f0c2c20> #<Tag:0x00007f744f0c2b58>

I would like to add the roller shutter Fibaro FGR 223. But I guess it is not supported by the zwave binding yet, The device just get identified as Z-Wave Node 043 (010F:0303:1000:5.0). I run OH 2.4 - stable.

@chris, can you double check and potentially add the device, please see attached note.xml. thx.

network_ddae85e4__node_43.xml (23.7 KB)

Yes, it is included -:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/983

You probably need to use a newer binding (ie 2.5 snapshot)

Hi Chris,

I have the same problem with my brand new FGR223. The device is unknown and the data between the xml file and PaperUi are different.

network_e8680794__node_13.xml (33.4 KB)

|zwave_beaming |true|
|zwave_class_basic |BASIC_TYPE_ROUTING_SLAVE|
|zwave_class_generic |GENERIC_TYPE_SWITCH_MULTILEVEL|
|zwave_class_specific |SPECIFIC_TYPE_CLASS_B_MOTOR_CONTROL|
|zwave_deviceid |4096|
|zwave_devicetype |771|
|zwave_frequent |false|
|zwave_listening |true|
|zwave_manufacturer |271|
|zwave_neighbours ||
|zwave_nodeid |13|
|zwave_plus_devicetype |NODE_TYPE_ZWAVEPLUS_NODE|
|zwave_plus_roletype |ROLE_TYPE_SLAVE_ALWAYS_ON|
|zwave_routing |true|
|zwave_secure |false|
|zwave_version |5.0|

More : at the inclusion, while a few seconds, the device name was corectly displayed and after that turned into Unknown Device.

Any idea ?

Zwave version : 2.5.0

Cheers.

After 5 attempts, inclusion work. But there is no blind_control channel. I’m testing with dimmer channel but so far no luck.

PS. nevermind for the diff xml/PaperUI (hex -> dec :slight_smile:).

same issue here. I have the device connected but can not get it to work properly with the dimmer channel. As you, I am also surprised that there is no blind_control channel. The FGR222 had one …

with a lot of trial and error and at the end, I do not even know why it works now … I got it to work with the switch_dimmer channel.
here is my configuration
ITEM:

Dimmer F1_Gallery_South_Shutter
    { channel="zwave:device:512:node17:switch_dimmer"}

SITEMAP:

Default item=F1_Gallery_South_Shutter label="Rolladen-Südseite"            icon="blinds"
Switch item=F1_Gallery_South_Shutter  label="Rolladen-Südseite"      icon="blinds"
                            mappings=[0="AUF", 100="ZU"]

What I would like to be able to do is to stop the movement of the blinds at any time with the switch-item (similar to what I would be able to do with a Rollershutter item-type)

Pull request created : https://github.com/openhab/org.openhab.binding.zwave/pull/1120

Great.
So … when and how can we use this changed channel?

You can use my compiled version if u want.
http://fejitatete.free.fr/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

I will give it a try.
I have another question for, as you also have the FGR223 in action:

Did you get the calibration to work? And if so, how?

Background: For me, the “forced calibration” did not work. I then calibrated manually by measuring the up- and down- times. Intially, this looked like it was working ok. But now, it is not working again … no clue why.
On the example below, I moved the shutter to 25% via the multi-state switch - and it shows the position as 7%

Did you get this added to the device database?

Chris is on holiday for a bit, so you’ll need to wait for him to get back before there is a build. But db needs to be updated first.

I closed the PR since I asked Chris to give me the write access on the Database.

The forced calibration work for me, both method : B button and PaperUI command.
But I have an issue with percent report. It does not work as intended. Do not know why at the moment.

Yes… but did you get access, and have you updated the device? If not, someone here can do it. :slightly_smiling_face:

No write access so far. I’ll wait.

What do you mean with “percentage report”?

The state reporting off the blinds is not correct and not updated.

The same effect here.
If i set slider to 50% for example, the log shows
Item ‘ZWaveNode011FGR223RollerShutter3_Dimmer’ received command 50
ZWaveNode011FGR223RollerShutter3_Dimmer changed from 88 to 50
ZWaveNode011FGR223RollerShutter3_Dimmer changed from 50 to 74
The blind moves down half way, but the dimmer slider reports 74.

If i move the blind manually by the momentary switch, i get no updates anyway

@sihui, can you take a look at this? There are multiple endpoints, which I haven’t had to deal with. I’m assuming all endpoints should be updated, but not sure if this is one of those cases where the standard has been to remove the Channel from endpoint 0. Here are the requested changes.