[SOLVED] Zwave binding: Fibaro fgr 223 - unknown device

Tags: #<Tag:0x00007f433c80a0f8> #<Tag:0x00007f433c80a030>

Please don’t expect support for own changes to the binding.

If you are using the official release: please wait until the changes got merged into the binding, this will take some more days.

It’s not linked to the binding design, it’s the pattern of the module I think. In the manual it’s described like this :

Endpoint 1:
Description: represents switch connected to the S1 terminal.
Endpoint 2:
Description: represents switch connected to the S2 terminal.

So I guess you have to link the channel blinds_control1 to a Switch1 and blinds_control2 to a Switch2.
The other thing if using only one switch is linking blinds_control to a Switch.
I don’t have this device so you may be need to tinker around a bit (or wait for a user with this device to respond).
Good luck.

The issue is the reporting of the blind level when physical button is used.

The blind position issue is related to the device itself. There is already an bug report existent at the fibaro support. So thats nothing the guys here can fix.

For more details see:

1 Like

any update on this?
fibaro has released a new firmware for these v5.1, has anyone tried it?

for anyone having a problem with the device updating the value back to OH, can you try this:
(i don’t have an FGR-233 yet, i will in a few days, so can’t try it)

create a rule:

rule "fgr233_fix"
  Item zwave_device_919b2a1d_node12_sensor_power changed

if (zwave_device_919b2a1d_node12_sensor_power.state == 0) {

sendCommand(Bedroom_Blind, "REFRESH")}


change “zwave_device_919b2a1d_node12” with your item
and “bedroom blind” to your roller shutter item
this will take advantage of the power change and send a refresh command when the power returns to “0”

although power reports are not sent for small changes… e.g 5-10%

Yesterday i got my hands on an FGR-233 with firmware 5.1 which i bought just for testing.

I can verify that it works perfectly with openhab.

The device calibrated on first time.

and the location is reported correctly as soon as the roller shutter stops.

You will have 3 controls blind control, blind control 1 and blind control 2

make sure you are using blind control 1.

“blind control” 2 will do nothing (i guess this is for lamella position which i don’t have) (exactly same behavior as fgr-222 - “lamella position”)

“blind control” will move the shutter but will not update blind control 1, and manual switches will not update its value as well (exactly same behavior as fgr-222 - “shutter position”)

good luck everyone

Hi All,

I am running 2.4 and have purchased 3 x FGR223’s and am unable to find the latest 2.5.0M4 Z-Wave binding as #825 and previous builds stop at #821.

Could someone point me in the right direction please?

Thank you!


By running this in the console, the dependencies will be taken care of for you (no need for a manual install)…

bundle:update https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar
1 Like

Hi Scott

Will this command update the binding installed from paper ui in openhab 2.4.0 to the latest zwave 2.5.0 snapshot or would we need to update openhab to the 2.5.0 milestone in order for it to work?

In theory, yes, but I have not done it myself (I use a snapshot build of OH). If it does not work or you want a manual installation, you could try this script. Some day soon, I will be changing this script to offer an option to use bundle:update.

Hi Scott,

I am pretty new to OH with Adam giving me alot of assistance and support over the last 9-12 months.

Thanks for your input and help, however I received the error below when trying to run your Bundle Update:

openhab> bundle:update https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar
Error executing command: Bundle https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar does not match any bundle

Have you already installed the zwave binding through Paper UI or the console? You’ll need to in order to update it, otherwise use bundle:install. It’s possible this won’t work in OH 2.4 due the massive changes in 2.5. But the manual install will work.

I ran the install option and got the below error.

Error executing command: Error installing bundles:
Unable to install bundle https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar: org.osgi.framework.BundleException: A bundle is already installed with the name “org.openhab.binding.zwave” and version “”

Thing is when I look at the Z-Wave binding in Paper UI It is in an uninstalled state (Version 2.4.0) but when looking at Things, they are all “Uninitialized”

I just spun up a 2.4 test environment and…

bundle:install https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

… worked just fine. Did you manually install a zwave binding? What do you see when you run this in the console?

list -s | grep zwave

Have you tried a restart?


Clearly I have done something wrong…

openhab> list -s | grep zwave
230 ? Installed ? 80 ? ? org.openhab.binding.zwave
239 ? Active ? 80 ? 2.4.0 ? org.openhab.binding.zwave

What I forgot to add to that is I installed the 2.4.0 binding via PaperUI to keep things working last night.

I can uninstall and rerun the command if needed.

bundle:uninstall 239