[SOLVED] Zwave Network very slow or not working after Update to 2.5

Here it is: https://1drv.ms/u/s!ApeehH4aJpB6vE_s_wF2W3DhqdC7

thanks for the tips guys!

I didn’t notice the processor load going up before the stick freezes.

Here is what i tested yesterday:
I took a different Pc with Ubuntu, installed Openhab 2.5.1.
I double checked the serial port user rights and the “-Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0” setting.
Only installed the Zwave Binding and used the new Stick with my restored network on it.
All the Nodes get recognized in the inbox, picked two roller shutters nearest to the controller and linked them to Items to test it.
And exactly the same problem!

Here is the log: OneDrive Link

At the end of the log, where i try to open/close the roller shutters, the same CAN message phenomenon explained by @chris reappears.

:frowning:

So tonight, as a last resort, i’m gonna reset and exclude the whole network and rebuild it one by one, to see if that works.

Thanks
Greetings
Yves

Anything specific I should look for?

The only thing that stands out here is that there are a lot of duplicated messages, and quite a few (occasional) rejected messages from the controller when we try and send something. These are possibly related in that if there’s too much network activity, then it will overload the controller and it can run out of memory (and then will reject commands).

Duplicate messages could be caused by protocol level issues - poor mesh, bad routes, retries etc. A heal could help.

As an example of what I mean -:

The second log shows some duplication, but also seems to indicate that this node is configured to send reports too often as while some messages are duplicated, we see a lot of messages from this device in short succession throughout the log.

I see some messages rejected from the controller, but nothing that indicates that the controller is locking up in this log. The log is reasonably short and the controller appears to work generally ok throughout the log as far as I can see.

Hi all,
just a little status update from my part.
I did reset my whole zwave network.
I excluded every node and reset the zwave stick.
I took the time to include the nodes one by one and periodically checking if the problem persists.
So far I’ve only added all my power connected nodes and it seems to work again! :smiley:
Tonight I will try the more time consuming task of adding all the battery powered nodes again.

Soo, it looks like there was something wrong with the network or some node saved on the stick. I don’t understand it, but i’m glad it looks like it’s working again even on my old but updated openhab install :smiley:

Thanks everyone for helping me troubleshoot this!

Greetings
Yves

1 Like

Just to be safe you may want to factory reset the nodes before including. Some cheaper devices especially seem to need that in my experience.

1 Like

https://1drv.ms/u/s!ApeehH4aJpB6vE_s_wF2W3DhqdC7?e=0uCuZi

This is a new zwave.log file. Most of the time, the Zwave devices react extremely slow, sometimes after a few minutes.

Perhaps the log viewer can shed some light. I am at work right now and cannot check.

https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Just to join the party, I have the same experience after upgrading to v2.5.x. My z-wave network has been stable and working really great with v2.4.x, but pretty much immediately after upgrading to v2.5.x I started noticing lags and other issues where nodes no longer connected, etc.

I see a lot of back/forth in the thread above re: HW issue, but in my case it really appears that the openHAB upgrade triggered this issue(s). I’m also using the Aeotec Zwave Stick.

You may have the same symptoms but a different issue. To reduce confusion please start a new thread.

I have the same issue, everything worked well with Openhab 2.4 and Zwave. I upgraded to Openhab 2.5 and now my Zwave is sometimes very very slow or even not working. I see the Zwave LED on my USB Stick permanently on when it is reacting slow or not. There is something wrong in 2.5.4 ;-(

Did you ever find the problem? I have used oh for years, and are starting to look at athom homey (eagerly waiting for oh3, if thatcdoes not fix the zwave laggyness. I sadly have to move

How many ghost nodes do you have?

Hello, what is the best way to check that?

My setup is mostly : 12x Hetait zdim 12 x heatit trfx3 thermostat and 8x fibaro socket plugs 2. 1x UZB controller.

I am experiencing extreme laggyness controlling lights. Especially after sending luke 10 20 30 % dim states. The nettwork will hang and after 10 sec or so the commands goes trough. And yes i never had any problems before upgrading from 2.4

Do the logs show Zwave and other addons reloading every minute? You may have some invalid addons causing them all to be reloaded every minute in attempts to load the invalid one.

The file to look at is usually /var/lib/openhab/config/org/openhab/addons.config. Stop openHAB before editing. Restdocs is a common culprit because it’s location changed in 2.5.

Hello! Do you have any nodes repeatedly showing up in your Inbox after Z-Wave discovery? You may have marked them as ignored. If they are added, these nodes will stay offline and they will be rediscovered after the Thing is deleted, but still show as offline. These are ghost nodes and they will mess with your network. There are lots of topics in the forum about them.

If possible, it is very helpful to include links to the device database…



I’m not sure of the model for the last one, but they all appear to be mains powered or I’d also suggest checking batteries. Being all mains powered, your Network Viewer image seems very odd. Do you possibly have the daily heal turned off? Could you describe how far apart the devices are and what the walls/floors are made of? Why is node 24 so popular?

If your network routing is anything like what is shown in that image of the Network Viewer, then pretty much all traffic is going through node 24. I would manually heal the mains powered devices, possibly spreading them out to strengthen the mesh. First though, have you power cycled the devices any time soon, including the controller? Some computers do not power cycle the USB ports when restarting, so power down completely and then start back up.

Hello, I have no ghost nodes and only one battery node. Why node 24 is so populer is beyond me (fibaroplug). Was wondering if i remove it from zwave network maybe things will normalize

I suggest doing a heal before excluding it. By any chance, do you move the devices around, or remove power from them? This can also mess up the routing.

I have a nigtly heal at 2Am, but it seems to screw up more than helping. I have used the zway software to heal the network (shutting oh down) and after started oh. That seems to help alot.
I am at point of offering money to anyone who can stabilize my zwave system system. It becomes too much for me handeling the backend (zwave binding) and coding my system (rules and stuff).
I have removed the node 24 and hoping after nightly heal it looks better.

This is how it looks after i removed 1 battery device and node 24, i also found ot I had an OLD firmware on the UZB stick and upgraded it.

I must say my cotroller is located at the far end of my attic, and is maybe not the best placement (running on a server) Maybe i will get a usb extention and try to place it more in the middle of the attic? I will have to wait for the nigthly heal again and see what happens.

Just be aware that those are not routes, but just reports of which neighbors can be seen by each node. It is likely that the Network Viewer looks the same when the device that was node 24 is added back into the network and It is healed. Also, you can heal individual devices. Z-Wave controllers should be centrally located, similar to your WiFi access point. The heat of a typical attic during summer is not healthy for electronics.

1 Like