[SOLVED] Zwave Network very slow or not working after Update to 2.5

Tags: #<Tag:0x00007efedb140808>

Hello all,
i updated from 2.4 to 2.5 a couple of days ago and the zwave network is very slow. Alot of nodes will not respond at all. Only the zwave binding seems to be effected, all the other bindings are working fine since the update.
I also observed the zwave controller going offline like in this post
I also see alot of Nodes change status in the event file e.g:

changed from ONLINE: Node initialising: PING to ONLINE: Node initialising: REQUEST_NIF

I’ve uploaded my zwave log to chris’s site but i dont understand enough to make any of it :frowning:
Also I’ve checked my addons.cfg and cleared cache etc but i’m running out of ideas what could cause this.
Any help will be much appreciated!
Thanks in advance.
Yves

  • Platform information:

    • Hardware: old Laptop. Aeotec Zwave Stick
    • OS: Ubuntu
    • Java Runtime Environment: 8
    • openHAB version: 2.5.1
  • addons.cfg is auto-generated and void including only comments

  • /openhab2/config/org/openhab/addons.config looks like this (i uninstalled the restdocs as stated in the relase notes)

action=“telegram”
binding=“wol1,network,exec1,astro,netatmo,hue,expire1,lgwebos,kodi,wifiled,weather1,zwave,miio,mqtt”
legacy=“true”
misc=“openhabcloud,market”
package=“expert”
persistence=“influxdb”
remote=“true”
service.pid=“org.openhab.addons”
transformation=“map,regex,xslt,exec,javascript,scale,xpath,jsonpath”
ui=“classic,basic,paper,habpanel,habmin,restdocs”
voice=“voicerss”

Thanks
Greetings
Yves

Also check the addons.config file in userdata. That one is normally populated by OH.
Also check for v1 bindings that may have moved to legacy. I do not know if they need to be removed from the files and reinstalled. If changing addons.config shut down OH first.

Hi Bruce,
thanks for the reply!
The addons.cfg i posted above is the one from userdata.
I checked again and none of my v1 bindings are concerned. Alll other bindings work perfectly by the way.
I’m starting to think that maybe the aeotec zwave stick could have a problem.
Thx
greetings
Yves

addons.config is a separate file, generated by openHAB. That is where users usually find problems.

Thanks Bruce,
yes i mean the addons.config from userdata is pasted above, the addons.cfg from the conf folder is all commented out. or is there a third file?

@chris
could you please have a look at my zwave log? (onedrivelink)
Maybe you see at a glance what the problem is? :slight_smile:
Many Thanks
Yves

Oops. slow for :coffee: to fully kick in. You may want to review the 2.5.x Release Notes too.

There’s certainly some strange stuff happening. I’ve not looked at huge detail at the log, but the following makes me think there’s something wrong with the hardware/OS and things are getting blocked -:

image

Here we see the binding send a request - it fails and the binding tries another request, and then again. Each time there is no ACK from the controller which should arrive quite quickly. Then we get a bunch of CAN messages all received very quickly - probably these are coming from the previous messages where we did not receive the ACK. I’ve no real idea why this is - the binding logs messages when it sends and receives the data, but maybe the OS is running slow for some reason at this point and things are getting blocked, we then swamp the controller, and it gets upset and sends all the CAN messages (CAN means that the controller received stuff out of order, but as we see, when we receive them, we’ve actually not sent anything).

1 Like

Many thanks @chris for checking :+1:

OK, i’m gonna revert back to 2.4 and see if it still works with 2.4 like it did before.

Yves

Looks like my Aeotec Stick is broken.
Because i now have the same problems on Version 2.4.
I also noticed that the light on the stick is flickering, i haven’t seen that before.
Normally it just circles thro the different colors, but now i noticed some flickering while going thro the circle or getting stuck on one color and even the light going out for some time.

I ordered a new one.
What a weird conicidence that it broke while i upadted oH.
Anyway thanks for the help guys!
Greetings
Yves

1 Like

I don’t think that it is a coincidence at all! I have two Aeotec sticks, and BOTH stopped working af ew days after the 2.5 update. There seems to be a major problem with openHAB Zwave now!
After the first stick died, I put in the second one, and that one died as well after a few days.
Horrible.
Any one please help!

I don’t think that’s likely. In general, the ZWave binding has not had much update since 2.4, and it certainly isn’t going to destroy ZWave sticks :wink:

If you have a problem, have you read the binding docs to see what to do when there is a problem? Enable debug logging to see what is happening - otherwise it’s really hard to help you.

1 Like

Well, the sticks are not really physically killed, they stop working (and even blinking) after a few minutes connected to OH 2.5.
Now, I set up a remote Raspberry Pi with ser2net and the stick connected to it and - Voila! It works like a charm.
So, I am very sure, OH 2.5.1 killed Z-Wave with Aeotec sticks. Considering I am not the only one with this problem, it might be a good idea to look into it… And I am pretty sure the binding manual won’t help me here :wink:

If you are using the serial abstraction, then that can cause problems as data can get lost.

Again, that is VERY VERY unlikely. There are a LOT of users of this binding. It is more likely that there is something specific to your system.

Really? Wow - maybe we should stop providing documentation.

I specifically asked if you could provide debug logs, but you haven’t done that still? Why not? If you want to understand what is happening, then please provide this as requested.

2 Likes

They are written to help us help you. If you do not help is the volunteers here are free to help somebody else and you have nobody to blame but yourself.

2 Likes

Hi, i just wanted to give a little update on my current troubleshooting status.
I was convinced that my Stick is broken, so i ordered a new one. (Gen5)
While waiting for the new one i even tried:
My old 2.4 Version same Pc. -> Same Problem
Fresh 2.5.1 install same Pc. -> Same Problem
Fresh 2.5.1 install different Pc. -> Same Problem

It looks like the Stick hangs / freezes, the light stops circling and just hangs/stays on a random color or stays off. And during that time it is unresponsive. Then suddenly at random time intervals the light starts blinking/ circling thro the colors again and the commands go thro again.
How long or when it freezes looks totally random which results in the zwave network being unresponsive, laggy a best. Commands getting lost or delayed when their go thro.

So today the new stick arrived and i used the aeotec backup and restore software to restore the network to the new stick. This worked as described with no errors.

Unfortunately when restarting openhab with the new stick, the exact same problem still persists :frowning:

So i guess the stick is not broken, but there is something wrong with the network saved on the stick? Is that possible?

My next step would be to reset the stick completely, exclude all my nodes and rebuild my entire 50 nodes network.

I’m gratefull for any other Ideas / Tips to help with my little problem.

Thanks in advance

Yves

One misbehaving node can cause network slowness too. Perhaps you had multiple problems initially. New Debug logs may help.

all this sounds like maybe there is something wrong with the serial port which you are plugging the stick into. Maybe plug it into another port?

On multiple systems? (old stick quoted) Unless a bad port is somehow damaging a stick. :frowning:

I’m not at all surprised. From the log I looked at earlier, it appears that the issue is with messages getting queued somewhere - the most likely issue is the host computer or something in openHAB hogging the processor. My guess is that this is causing things to run slow and queue all the serial traffic. These all finally get sent to the controller, and it is then unhappy with the sudden deluge of data being sent.

1 Like

OK, I have a zwave log file now.