[SOLVED] ZWave problem moving to PI4

I am moving to a PI4 latest OS
Latest Milestone M6
Backup old system PI3 Latest OS latest OpenHAB M6
Restore on Pi4
Everything works but i can no get my ZStick Aeon Gen5 to to ONLINE.
Have changed to ttyAMA0

pi@openhabpi4:~ $ dmesg -T |grep tty
[mån dec  9 12:11:55 2019] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M cma=256M  smsc95xx.macaddr=DC:A6:32:4A:7F:04 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000  console=ttyS0,115200 console=tty1 root=/dev/sda1 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[mån dec  9 12:11:55 2019] console [tty1] enabled
[mån dec  9 12:11:55 2019] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2
[mån dec  9 12:11:55 2019] console [ttyS0] disabled
[mån dec  9 12:11:55 2019] fe215040.serial: ttyS0 at MMIO 0x0 (irq = 36, base_baud = 62500000) is a 16550
[mån dec  9 12:11:57 2019] console [ttyS0] enabled
[mån dec  9 12:12:09 2019] usb 1-1.4: FTDI USB Serial Device converter now attached to ttyUSB0

I get OFFLINE - BRIDGE_OFFLINE Controller is offline.
Nothing in the log

2019-12-09 13:00:32.841 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyAMA0'
2019-12-09 13:00:32.880 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2019-12-09 13:00:32.976 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2019-12-09 13:00:32.979 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.


You need to connect your stick through a USB2 hub to the Pi. The stick is telling the Pi it supports USB3 when it does not.

1 Like

I am using USB 2 port (not Blue) for the stick.


Not sure if that works. I know from here & Pi forums that a hub was recommended as a workaround. I just thought I would mention it. Perhaps others using a Pi 4 can chime in.

1 Like

USB 2 Hub did the trick.

1 Like

So, it does not work with the USB2 port on the Pi4?
Thanks for verifying and updating us.

I can confirm this worked for me as well…

If you have a long usb cable (>5m) between the pi and the stick it will work, too.