[SOLVED] Zwave secure inclusion not working on Qubino Flush Dimmer (ZMNHDD)

I cannot do a secure inclusion of my Qubino Flush Dimmer device (ZMNHDD). The Qubino Flush Dimmer device is included ‘non secure’. I.e. the inclusion is successful but security is not used.

To my understanding, on the device the steps are the same for ‘secure inclusion’ and ‘non secure inclusion’. It is up to the “gateway (hub)” to do secure inclusion or not.

The attached log shows that there is no SECURITY command class in AddNodeToNetwork ADD_NODE_STATUS_ADDING_SLAVE (node 41). As consequence, the openhab zwave binding does not perform secure inclusion.

zmnhdd_not_secure_included.log (173.8 KB)

Some infos:

  • I am using the current openHAB 2.4 with the ‘normal’ zwave binding 2.4.0. Part of the openHABian installation on a Raspberry Pi.
  • The “Secure Inclusion Mode” is set to “All Devices”.
  • Controller is an Aeotec Z-Stick Gen 5 ZW090.
  • SW Version of the Qubino Flush Dimmer device is 1.1
  • A temperature sensor is connected to the Qubino Flush Dimmer device.
  • I started inclusion by pressing the S button.
  • Neiher inclusion nor exclusion worked for me by toggling the I1 switch 3 times within 3 seconds.

About the configuration parameter no. 250:

Parameter No. 250 – Unsecure / Secure Inclusion
Flush Dimmer supports secure and unsecure inclusion. If the gateway (hub) does not enable the device to be included as secure, it is included as unsecure while retaining the same functionality.
Values (size is 1 byte dec):
• default value 0
• 0 – Unsecure Inclusion
• 1 – Secure Inclusion

I would assume that this parameter only states whether device was securely included or not. True?

Does somebody know how I can securely include the Qubino Flush Dimmer?

I contacted the Qubino/Goap support on this problem: the exceptionally quick and competent support there clarified that my device with part number “ZMNHDD1 H1S1P1” is too old to support the S0 secure inclusion (the current ZMNHDD devices do support secure inclusion).

Problem “solved”!