[SOLVED] Zwave, unknown device NEO Coolcam power plug

Tags: #<Tag:0x00007f43374ce4e8> #<Tag:0x00007f43374ce420>

More correct : there are no items that can be linked.

Thanks for the further information about your problem, but please (please!) can you provide a log during inclusion if you think that’s the problem (I don’t) and the other information I requested. It’s really impossible to help you if you don’t provide information on your problem.

I see what I can do.
This is the xml-file for node 6.
network_e535530e__node_6.xml (10.5 KB)

I will try to get the log from the inclusion process but I want to let you know that I included another device just befor or after the powerplug. The other device did seem to do what was expected but now 24 hours later I see that it does not report states back.

So in other words, I get the feeling that maybe the system is having some issues with the two inclusions. If I can’t find the solution then I will exclude both devices again start over one by one.

Ok let me check current log, see soon! :slight_smile:

This looks fine - I think the inclusion process is working fine.

Please can you answer the questions from above -:

These are important to allow me to understand what the issue might be.

This is my system:
Rasp3
Openhab2.4.0-1 (install from image)
Aeotec Gen 5 USB

Inclusion was done activating the proces through openhab (and not by pushing the Aeotec button like I did before)

This is the Log from the beginning of the inclusion proces until a few hours later.
Node6 is the Neocam powerplug
Node 7 is temp/humid sensor

LogInclusionNode6&7_1.txt (593.8 KB) LogInclusionNode6&7_2.txt (523.4 KB)

Let me know if you need more.

Please don’t doubt my appreciation for your support!

Thanks. This explains your problem - you are using an old version of openHAB and you need to update at least the ZWave binding to use the device that you are trying to use. I’d suggest to use the SNAPSHOT binding.

You can update with the script below -:

2 Likes

Thx @chris,

I will read things through and let you know the outcome.

Grts
Mario

1 Like

Hi @mariofrombelgium,

Yes, It is working, no problems at all. But I’m on the snapshot release, I think that’s the problem you are having. I had the same from previous builds. They were seen as zwave devices, but without any info.
I also added a motion sensor, wall-switches and they are all working perfectly!
It’s really nice stuff. Good quality, looks good and they work well. and for much better pricing then fibaro at the moment…

/Jasper

Thank you @chris for all the work!
I’ve made a general thank you in the community in a different post. :wink:

1 Like

For sure - the device was not in the database for 2.4, so a newer binding is definitely required.

1 Like

all the Neo devices I have now work like a charm! Really nice!

Thanks - others also help a lot - especially @sihui and @Bruce_Osborne with database work which really helps :slight_smile:

2 Likes

The thank you post is for all who are dedicating their time to develop, maintain OpenHAB and all the community members who are supporting each other. It’s just wonderful to be part!

/Jasper

4 Likes

Hi @JdeJong, Before I launch a new post with my issues I’m having with this new Neo Coolcam power Plug I would like to know whether you had to make some adjustments to the plugs before they worked properly.

After upgrading my Z-wave binding to the current snapshot it looked like it was working properly.
Now I have all items available for linking.(was not the case before)

The swith item however does not turn off the poweroutlet. I hear the plug switching (when I toggle the switch from within openhab) but the light stays on.
In other words the communication between controller and plug seems to work (I hear the click in the plug) but the result is…nothing.

The Volt measurement item shows that there is 220V “pulled” from the plug but when I turn off the light, by means lightswitch, the output of 220V does not change. However when I toggle the switch of the Neo Plug(from within openhab) then the output of the Volt measurement gets toggled between 0 and 220V

What am I overlooking?

Grts,
Mario

I succesfully updated the z-wave binding.
When rediscovering the Neo Coolcam Power plug I instantly got the necessary items available for linking. So that looked like “problem solved”.

However, the plug behaves strange (see my post just before this one)

Now I notice that there are two lines of this device( NAS-WR01ZE) in the database. When I go over the parameters I see that the “second one” (not sure how I can see the difference) has the parameters set as described in the manual.

So to me that looks like my thing is “linked” to the wong device in the database…?
Is that possible? Of so, how can I solve the issue?
Or do you see another cause?

Regards,
Mario

Please post your xml file.

network_e535530e__node_6.xml (10.5 KB)

This is your device according to your xml file:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1014

Link the switch_binary channel to a switch item:

Switch Neo_PowPlug { channel="zwave:device:controller:node6:switch_binary" }

Make sure you have deleted the Thing and readded it (don’t exclude).
If it does not work post a debug log showing the switch action.

Edit: corrected link to the database

1 Like

Hi sihui,

I basically returned from an update to the snapshot so I had to rediscover the thing from. Also the swotch_binary was linked to a switch.

Anyway I just deleted the linked items and after that also the thing itself. Did a new discovery and linked the switch_binary to a switch item.

Same result!

This is the Logfile as of the newly discovery:NeoCoolCamPowerPlug.txt (43.6 KB)

I can’t see anything wrong, it sends the command, the controller receives the command and the state is updated:

I can only suspect a hardware error:

The swith item however does not turn off the poweroutlet. I hear the plug switching (when I toggle the switch from within openhab) but the light stays on.

1 Like