[SOLVED] Zwave: unknown device & NPE


I’m new to OH, trying to migrate my zwave setup from Vera.

Installed openhab-transport-serial and latest snapshot of z-wave ( It successfully detected my Z-Stick Gen5 which was already paired with a Cooper RF9534-NSG dimmer which is almost in the database (but is not approved), with a “small” difference in manufacturerRef: 4449:0001 vs 4449:0002 in the database.

Dimmer shows up in the inbox as an unknown device. At the same time I see this in the log:

18-09-15 16:57:16.888 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 001A:4449:0001::3.4

Then when I’m trying to change device location I get this

2018-09-15 16:58:22.858 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:512:node2/config'
java.lang.NullPointerException: null
        at org.openhab.binding.zwave.handler.ZWaveThingHandler.handleConfigurationUpdate(ZWaveThingHandler.java:805) [222:org.openhab.binding.zwave:]
        at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration(ThingRegistryImpl.java:92) [108:org.eclipse.smarthome.core.thing:0.10.0.oh230]
        at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.updateConfiguration(ThingResource.java:425) [118:org.eclipse.smarthome.io.rest.core:0.10.0.oh230]

PaperUI tells me that “This device has not been fully discovered by the binding” and I don’t see any way to control it.

Crudely changing manufacturerRef to 4449:0001 in thing/cooper/rf9534_0_0.xml makes it work, but NPE on setting location is still there.

Should I submit a new database entry?

Yes as yours is a different device type than the one that’s already in the db. Every device type and sometimes even firmware versions are different and will require their own entry.
And remember you need to wait for the new entry to be made available as part of the next snapshot.

OK, thanks.
NPE reported.

Yes - it is in the database an is approved.

It looks like the location is returning null. Please provide debug log that shows the data that is being passed into the configuration.

No - the current entry just needs to be updated to include your devices IDs as per the guide.

As I wanted to do a database update this morning, I’ve added your device IDs to the existing entry.

great, thank you!