Solving 'myopenhab is offline'

Beware, in hindsight this might not be the best solution. The oracle java might interfere with the openhab start up. The Zulu Javathat comes with raspbian should be Ok for myopenhab, it may just take a bit longer to kick in.

For various reasons I did a fresh install of Openhabian.
Subsequently I could not get my on line, inspite of having inserted the proper secret and uuid codes.
In the past, I have had that happen, but then usually within a short time, it would be online.
Not this time.
Came across the suggestion that replacing openJDK Java Oracle java would/could solve this problem.
[SOLVED] My.OpenHAB OffLine
As I was under the impression that the latest Raspian came with Oracle java and thus I presumed the openhabian distro as well.
However, java -version command showed I had openJDK. Hmmm, that same distro worked for me in the past.

Anyway, eager to get myopenhab on line, I decided to replace the openjdk by oracle java.
Behold… I was immediately on line!! Still a bit puzzled by that as it has worked before without changing Java

For those who want to try it, here is how:

Check what java version you have with
java -version

then do an update:
sudo apt-get update
then install oracle java
sudo apt-get install oracle-java7-jdk

when that is done, select which javaversion you want to use with:
sudo update-alternatives --config java

You are subsequently presented with a menu that gives you options to choose.
Choose Oraclejava

Now beware, this is not a solution for any random ‘myopenhab is offline’ You got to make sure that you have filled out the proper secret code and uuid in You will find these codes in your openhab system:

        uuid (find in openhab2-userdate) 
        secret (find in openhab2-userdata/openhabcloud)

and you also need to have the OpenHab Cloud Connector add-on installed, but if you then still have trouble, maybe OracleJava will solve it

1 Like