Some Icons/Images missing in UI

Hi Everybody,

just working on finally getting our home automated.

Installed 1.7.1 on fresh Raspbian install on RB2. Followed instructions on Wiki. Downloaded demo. Everything works as expected, but I’m missing icons for temperature and light bulbs. All other icons seem to be there.

Here’s a picture of what it looks like:
No icons

The icons exist in the webapps/images directory. The same configuration files installed on my Win7 PC work just fine and I get the images. Interestingly, when I load the UI while openhab is still starting up, I do see at least the ‘light off’ icons load. Once I hit reload after that, they’re gone.

I did a clean fresh install of Raspbain and openhab, just to be sure. No change. I also used my own, rather minimal sitemap and items, with only a few bindings. Still no luck.

Does anybody else experience this? Any idea what’s causing it?

Hey Stefan…

Check the File Permissions, maybe this is the Problem … from my side i have to change the chmod to 644 to load the images …

Hi Daniel,

I will check today after work, but I very much doubt that it has to do with permissions for several reasons:

  • I start openhab with ‘sudo’
  • The icons that don’t show are located in the same directory as the items that do show and presumably have the same permissions
  • The icons do show up briefly if you open the UI while openhab is still loading



If you installed openHAB using apt-get and start it using the sudo service openhab start to execute it then openHAB is actually running as the openhab:openhab user:group, not root:root.

Beyond that I don’t have anything offer. It is an odd error. Have you tried the sitemap with one of the smartphone clients?

I started openhab as service and just straight with “sudo ./” - no difference.
Using the Android app yields the same results. Images for most items are there, but not for lights or temperatures.

Changed permissions on webapps/images. Problem persists when starting with
But when starting as a service the icons show up now.

No idea why this is, but it works now, so I’m shutting up.