Something broke basicui

I guess after upgrading oh or software on the server running OH2 something broke basic ui and possibly also rest API. Yes I know - should not have updated everything in one go! :frowning:

With rest, I have an errror icon at the bottom, wich gives me {"schemaValidationMessages":[{"level":"error","message":"Can't read from file http://xenon:8080/rest/swagger.json"}]}
… and app does not seam sot work anymore.

With basic ui, I get the initial sitemap, but cannot click further on some groups;

Here ‘Entreplan’ works as it should but not ‘Bottenvåning’. i.e. if I click ‘Entreplan’ it will give me;

In Chromium, If I click ‘Bottenvåning’, nothing happens.
However, if I instead enter the path in the browser (e.g. http://xenon:8080/basicui/app?w=0001&sitemap=beckasinen ) it works (i arrive to ‘Bottenvåning’)! In Firefox, I get the URL in the edit box, when pressing, ‘Bottenvåning’, and if I then press reload, I get the proper content. Also if I just press enter in the URL edit field on Firefox.

I have tried to update oh this morning again, removing runtime/ userdata/cache/* userdata/tmp/* but same problem.

Has anyone seen something similar? :confused:

Yes. Seeing similar. It seems to be links that have special characters that cause issues. Special date formatting, accents, degree symbols, etc. If you hit F12 and look at the debugging, you might see a JS error: undefined entity. In my case, I can reproduce it at will with the degree symbol (°)

The PTAC and HVAC links will hang every time.

Many are reporting it, unfortunately in different threads: BasicUI: Warnings in Log

Yes, I have those!
But I have had the warnings mentioned in the other thread even before, for a date item.

But you are correct: if I remove the accented characters from descriptive text, it seams to work again.
I know java was updated on the server, could this be the issue? I don’t think it is OH2 that changed this behavior.

Since it also affects the demo sitemap (for the “Outside Temperature” entry), I assume that it must be due to some recent change in the Basic UI.
Please best enter an issue at for it.

No… I have it for quite a while. Would not relate it to something recent

Ok, nonetheless it would be good to create an issue to get it solved.

ok my above statement was about the Warnings in the log
… still everyting was working

now I updated to the latest nightly and the whole navigation on Basic UI is broken by using special characters

I created my old issue again:


I confirm the same issue with accent caracters (é, è, …) in chrome with yesterday build BUT not with Beta2 build
Navigation from any group with those accent caracters in their label is not working. You click on your group but no action …