Sometimes it helps to read about people's dumb mistakes

When I first added myopenhab to my android app, it worked right away. Then somewhere last week… because of some other problems, I reinstalled my phoneapp and added myopenhab again and it didnt work.
I kept trying and trying, changed https into http and back, switched ttl of and on back and forth. Nothing helped.
i could still log in via my webbrowser, that was no problem, so what was it.
And then this morning I thought… could it be that I typed my password wrong?? Noooo, it couldnt be could it?? So I re-checked my password in my browser…Yeah, thats the one I put in my phone app last week. hmmm, why don’t I give it another try. Low and behold… it worked immediately.

Now there are two possibilities

  1. I put in the wrong password after I reinstalled the app last week.
  2. I made no mistake, Myopenhab just happened to be off line for a week and just happened to work again when I retyped my password.

I am sure it is number 2… it must be… I dont make such dumb errors.

Anyway Moral of the story… most of the problems I had with openhab in any type shape or form were caused by dumb typo’s. Not all, but most. It really pays to take nothing for granted and check and recheck.

Other stupid mistakes I made:
-used the wrong IP for my broker
-forgetting to connect an ESP node
-Adding an item to the wrong group, wondering why it didnt appear on screen in the group I was expecting
-forgetting the closing " on an item label
-Copying an example , forgetting to change ‘broker’ into the actual name of my own broker
-forgetting to install a binding.

Think of any mistake and I probably made it