Somfy Tahoma Bridge Connection Error


Does anybody else experience connection issues with the Somfy Tahoma Bridge recently?

A few days ago the bridge started to go offline and online frequently throughout the day. Since two days the bridge won’t connect at all anymore, giving me an error "Communication Error: Authentication Challenge“. The Connexon App still works fine, connectivity is okay, credentials are correct…


yes I have the same issue since yesterday evening. I can’t control the blinds from the KNX buttons anymore, but the SomfyTahoma app works (as it is a local connection). Hope Somfy will fix the issue and it is not a permanent change in their API.

Any idea what could be wrong? I tried stopping Openhab, cleaned the cache and rebooted, as suggested in a different thread but without any success.

The error stays the same:

2021-04-02 11:26:51.589 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'somfytahoma:bridge:c472dfdf' changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Authentication challenge


I’ve got the same issue since today in the morning.
Did you find a solution?

Not yet unfortunately. But there’s another thread where some people are currently debugging and trying to figure out what’s happening: Tahoma Binding compatible with OH2 - #540 by gcatellani

A solution has been found. Eventually, Somfy made some changes to their rate limit. locks the account after too many connection attempts from Openhab.

  1. Try disable the binding for a few hours, so openhab stops making connection attempts. Renable after a few hours and see if the problem has solved.
  2. If the problem persists, go to and reset your password after disabling the openhab binding. Wait for a few hours before you re-enable it and the issue will be gone.

Optional: Change the request threshold in openhab from 30 to 60 seconds to make sure the issue is not occurring again.

My system is now back online and hasn’t stopped working in 24 hours.

1 Like

anyone else also connection problems with somfy since today?

Hi Manuel,

I had the same issue after installing the latest Somfy firmware update yesterday.

Disabling the bridge and re-enabling after an hour fixed the issue for myself.

I assume there’s some sort of rate limiting implemented and Openhab tries to reconnect too frequently for Somfy to reset.

Same here. Getting '(COMMUNICATION_ERROR): Error logging in (check your credentials)"
since yesterday. Checked and resetted passwords, cleared cache and all yet to no avail. Just disabled the bridge and will re-check in a few hours. Hopefully this will resolve the issue.

I all,

thanks for advice, I will disable the bridge and will wait for a few hours an reenable.

@Marty did you cleared the cache of whole openHAB or only the somfy binding?
Because the last time I cleared the cache all my zwave devices were gone.

cleared (complete) Openhab cache thru the openhab-cli. But this did not resolve the issue at this moment so no point in trying for you at this point.

btw. This thread is similar:

Disabling the Gateway / binding over night seems to resolve the issue for most users. So try that first!

all right, waiting is not my strength but I probably have no choice :sweat_smile:

waiting fixed the problem. Thanks for support :ok_hand:

Same here. Disabled the Bridge for 4Hrs and now everything is back online.

same here, working again after disabling the bridge for some hours. Thanks :partying_face: