Somfy Tahoma/Connexoon awning control stopped working

I am using the official Somfy/Tahoma binding for more than 2 years for the control of my outside awnings and it worked so far without any problems.
However since the Upgrade to OH 2.5.5 it seems that i can no longer control my awnings via OH. I am using a Connexoon box and I already checked that my Somfy account is still active and I can log in successfully via Web.
In the logs I can find the following error when I try to change the awning position via OH:

2020-07-05 11:29:34.160 [WARN ] [nal.handler.SomfyTahomaBridgeHandler] - Apply command response: {"errorCode":"INCOMPATIBLE_VALUE","error":"setDeployment() : Invalid value for command parameter p1 : expected integer value between 0 and 100 but got 100.0"}
2020-07-05 11:29:34.189 [WARN ] [nal.handler.SomfyTahomaBridgeHandler] - Apply command response: {"errorCode":"INCOMPATIBLE_VALUE","error":"setDeployment() : Invalid value for command parameter p1 : expected integer value between 0 and 100 but got 100.0"}
2020-07-05 11:29:36.443 [WARN ] [nal.handler.SomfyTahomaBridgeHandler] - Apply command response: {"errorCode":"INCOMPATIBLE_VALUE","error":"setDeployment() : Invalid value for command parameter p1 : expected integer value between 0 and 100 but got 0.0"}
2020-07-05 11:29:36.528 [WARN ] [nal.handler.SomfyTahomaBridgeHandler] - Apply command response: {"errorCode":"INCOMPATIBLE_VALUE","error":"setDeployment() : Invalid value for command parameter p1 : expected integer value between 0 and 100 but got 0.0"}

I still can control the awnings with the original remote from Somfy but no longer via OH.

Any help appreciated, thank you!

How are your Things and items configured? Per the log OH is looking for an integer so you may need to change your config or use a rule and proxy item.

Things are discovered by OH and not organized by a .things file. My items file looks like this:

Dimmer JA_BALK_J1 "Terrasse 01" <blinds> {channel="somfytahoma:awning:SOOG:85b19008-4099-41cb-870a-2573cbd246ba:control"}
Dimmer JA_BALK_J2 "Terrasse 02" <blinds> {channel="somfytahoma:awning:SOOG:f0bf3227-a718-4798-b193-565a085b2d79:control"}
Dimmer JA_BALK_J3 "Terrasse 03" <blinds> {channel="somfytahoma:awning:SOOG:d0dbd266-544d-4e14-adcf-cbb79b1bc7d7:control"}
Dimmer JA_BALK_J4 "Terrasse 04" <blinds> {channel="somfytahoma:awning:SOOG:63d03645-4e9e-421e-b654-0a055cc44fc2:control"}

So I am using a dimmer item type in order to have the scroll bar in BasicUI. It worked always until recently…

How does the commands look in OH logs and have you tried changing the item type to Rollershutter?

You may need to add [%.1f] to your Dimmer item if Rollershutter does not work.

Examples from the doc’s for both Number and Rollershutter:

String TahomaVersion "Tahoma version [%s]" { channel="somfytahoma:gateway:237dbae7:1214-4519-8041:version" }
Rollershutter RollerShutterBedroom "Roller shutter [%d %%]"  {channel="somfytahoma:rollershutter:237dbae7:31da8dac-8e09-455a-bc7a-6ed70f740001:control"}
Dimmer RollerShutterBedroomD "Roller shutter dimmer [%.1f]"  {channel="somfytahoma:rollershutter:237dbae7:31da8dac-8e09-455a-bc7a-6ed70f740001:control"}
1 Like

Thank you very much, that did the trick! After changing to Rollershutter item type my awnings started moving again :wink:
However, I still wonder what the root cause is. There must have been a change either in OH Dimmer Type or in Somfy binding or whatever. My old config with Dimmer items worked for more than 2 years with several OH releases without any problem…

1 Like