Sonoff TH16 stops sending Temp and Humidity readings!


(Simon Crump) #1

Hi Everyone,
Well, I have been playing with openhab2 for a few weeks now and managed to get it all set up with a rasberry Pi3. Just to get into it I flashed a Sonoff TH16 with Tasmota and set things running with MQTT and Mosquitto.

After a lot of trial and error, forum reading etc etc it worked. TH was reporting both temp and humidity. Fine for a week or so sat on the desk.

Last night it just stopped reporting temp and humidity. Switch and relay work fine.

I have used MQTT.fx and can see that the POWER, RESULT and STATE data is coming in but now no temp or humidity.

Anyone any ideas? I only have one AM2301 and its setup on GPIO14 which it has been from the start.

My next move is to get some more AM2301’s to rule out the sensor failure. But strange it just stopped.
I was playing around with items and sitemaps but that would not affect MQTT.fx I assume…

Anybody else experience this?

Oh and its not the jack plug and case problem…

Cheers

Crumpy


(Vincent Regaud) #2

You are assuming correctly because:

The sonoff is not sending the data

Di you dig into your sonoff config?
Have a look at:

There is a large list of commands you can enter in the sonoff console (or http or mqtt) that will tell you what is going on inside the beast.


(Simon Crump) #3

Ah yes, good point. Forgot about the console. Will give that a look over. Cheers


(Simon Crump) #4

Well I have had a quick look through the commands and can not find much to decide if the sensor is operating or not. Any other ideas?

Cheers

Crumpy


(Vincent Regaud) #5

Check your connections, reflash the sonoff…
Failing that you may have a faulty sensor


(Simon Crump) #6

Hi Vincent,

Yes already tried the connections and reflashed to latest update.

Will have to get some more sensors!

Cheers

Simon


(Simon Crump) #7

Well looks like it’s a broken wire in the cable. Bend the cable and it comes back online. Will have to break out the multimeter and find out where! Thanks for your help anyway, I assumed I had something wrong as the sensor is quite new and unused really.

Update

It was not the sensor, it was the socket on the PCB, I gently pressed down the internal pins on the socket and it now has good connection, works perfect again.