Sonos binding - setting callbackUrl in text config?

I’ve just added a second NIC to my OH2 installation, and at that point my sonos notifications just stopped dead. Turns out the sonos was trying to call back to the second IP and not the primary, so the uPnP discovery was failing (guessing). I fixed it by setting the callbackUrl to the primary IP via the PaperUI… However, all of my config is in a git repository and I deploy using Ansible, so I would really like to configure this parameter texturally… Where exactly can I do this? The docs are sketchy, only saying that the ‘callbackUrl’ parameter can be set for ‘binding:sonos’. I’ve tried creating a services/sonos.cfg, and adding binding config options in the .things and .items files for my devices with no joy.


Hi Geoff, same problem to me.
I have also created the sonos.cfg file in services


But without luck.
Could you solve this meanwhile?

Try replacing callbackUrl by org.eclipse.smarthome.binding.sonos:callbackUrl

In case it works, please propose an enhancement of the documentation.

Thank you, but unfortunately with


in sonos.cfg it don’t work.